aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/gemini/Makefile
diff options
context:
space:
mode:
authorImre Kaloz <kaloz@openwrt.org>2009-05-11 18:27:33 +0000
committerImre Kaloz <kaloz@openwrt.org>2009-05-11 18:27:33 +0000
commitfb452f9a5ab5d05c5a21a75c14486adce0807b2f (patch)
treee70b39741af75ce3471a513e20c6e46c6a22f6e3 /target/linux/gemini/Makefile
parentcdce1e17d755f7e34249f3e336e6dc7641b1648e (diff)
downloadupstream-fb452f9a5ab5d05c5a21a75c14486adce0807b2f.tar.gz
upstream-fb452f9a5ab5d05c5a21a75c14486adce0807b2f.tar.bz2
upstream-fb452f9a5ab5d05c5a21a75c14486adce0807b2f.zip
add preliminary support for the successor of the storm port
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@15772 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/gemini/Makefile')
-rw-r--r--target/linux/gemini/Makefile19
1 files changed, 19 insertions, 0 deletions
diff --git a/target/linux/gemini/Makefile b/target/linux/gemini/Makefile
new file mode 100644
index 0000000000..9b3a0de83c
--- /dev/null
+++ b/target/linux/gemini/Makefile
@@ -0,0 +1,19 @@
+#
+# Copyright (C) 2009 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+
+ARCH:=arm
+BOARD:=gemini
+BOARDNAME:=Cortina Systems CS351x
+FEATURES:=jffs2 broken
+CFLAGS:=-Os -pipe -march=armv4 -mtune=arm9tdmi -mno-thumb-interwork -funit-at-a-time
+
+LINUX_VERSION:=2.6.30-rc5
+
+include $(INCLUDE_DIR)/target.mk
+
+$(eval $(call BuildTarget))