aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/etrax
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2010-04-24 13:34:51 +0000
committerNicolas Thill <nico@openwrt.org>2010-04-24 13:34:51 +0000
commit484051d05518b1f7fb53b535e84302849080272d (patch)
treed4fcbe83d1ea442b9b0a2470e95fc222536a114c /target/linux/etrax
parent9ae19dcf8799314a89c7eabd57304c046f50d513 (diff)
downloadupstream-484051d05518b1f7fb53b535e84302849080272d.tar.gz
upstream-484051d05518b1f7fb53b535e84302849080272d.tar.bz2
upstream-484051d05518b1f7fb53b535e84302849080272d.zip
package/kernel: move target specific modules to their own target files
SVN-Revision: 21132
Diffstat (limited to 'target/linux/etrax')
-rw-r--r--target/linux/etrax/modules.mk23
1 files changed, 23 insertions, 0 deletions
diff --git a/target/linux/etrax/modules.mk b/target/linux/etrax/modules.mk
new file mode 100644
index 0000000000..9c3bb0d72b
--- /dev/null
+++ b/target/linux/etrax/modules.mk
@@ -0,0 +1,23 @@
+#
+# Copyright (C) 2010 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define KernelPackage/usb-etrax
+ SUBMENU:=$(USB_MENU)
+ TITLE:=Support for the ETRAX USB host controller
+ DEPENDS:=@TARGET_etrax
+ KCONFIG:=CONFIG_ETRAX_USB_HOST \
+ CONFIG_ETRAX_USB_HOST_PORT1=y CONFIG_ETRAX_USB_HOST_PORT2=y
+ FILES:=$(LINUX_DIR)/drivers/usb/host/hc-crisv10.$(LINUX_KMOD_SUFFIX)
+ AUTOLOAD:=$(call AutoLoad,50,hc-crisv10,1)
+ $(call AddDepends/usb)
+endef
+
+define KernelPackage/usb-etrax/description
+ Kernel support for the ETRAX USB host controller
+endef
+
+$(eval $(call KernelPackage,usb-etrax))