aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/etrax/patches/generic_2.6/004-extra_optimization.patch
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-09-06 16:27:37 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-09-06 16:27:37 +0000
commit56231056ea784f1cec6450f649b1adaed1f56366 (patch)
tree7b130d72d854cde2bcd3af8b11bd0f7be3dbff6a /target/linux/etrax/patches/generic_2.6/004-extra_optimization.patch
parente1184aaa1a7a5e5eeef8e072bf0ea98c291be22a (diff)
downloadupstream-56231056ea784f1cec6450f649b1adaed1f56366.tar.gz
upstream-56231056ea784f1cec6450f649b1adaed1f56366.tar.bz2
upstream-56231056ea784f1cec6450f649b1adaed1f56366.zip
strip the kernel version suffix from target directories, except for brcm-2.4 (the -2.4 will be included in the board name here). CONFIG_LINUX_<ver>_<board> becomes CONFIG_TARGET_<board>, same for profiles.
SVN-Revision: 8653
Diffstat (limited to 'target/linux/etrax/patches/generic_2.6/004-extra_optimization.patch')
-rw-r--r--target/linux/etrax/patches/generic_2.6/004-extra_optimization.patch13
1 files changed, 13 insertions, 0 deletions
diff --git a/target/linux/etrax/patches/generic_2.6/004-extra_optimization.patch b/target/linux/etrax/patches/generic_2.6/004-extra_optimization.patch
new file mode 100644
index 0000000000..3a8dfdcd00
--- /dev/null
+++ b/target/linux/etrax/patches/generic_2.6/004-extra_optimization.patch
@@ -0,0 +1,13 @@
+diff -urN linux-2.6.19.old/Makefile linux-2.6.19.dev/Makefile
+--- linux-2.6.19.old/Makefile 2006-11-29 22:57:37.000000000 +0100
++++ linux-2.6.19.dev/Makefile 2006-12-14 03:13:23.000000000 +0100
+@@ -513,6 +513,9 @@
+ NOSTDINC_FLAGS += -nostdinc -isystem $(shell $(CC) -print-file-name=include)
+ CHECKFLAGS += $(NOSTDINC_FLAGS)
+
++# improve gcc optimization
++CFLAGS += $(call cc-option,-funit-at-a-time,)
++
+ # warn about C99 declaration after statement
+ CFLAGS += $(call cc-option,-Wdeclaration-after-statement,)
+