aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/etrax/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-09-08 19:55:42 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-09-08 19:55:42 +0000
commita9d683ca912b2c4837b2e65909c09ca01babe3df (patch)
tree6cbca6e13dd0bb18c9d9f1d4baa9a0ea7801b959 /target/linux/etrax/Makefile
parent4a2e4920b1d909ca254853b0dce46af3123e8f74 (diff)
downloadupstream-a9d683ca912b2c4837b2e65909c09ca01babe3df.tar.gz
upstream-a9d683ca912b2c4837b2e65909c09ca01babe3df.tar.bz2
upstream-a9d683ca912b2c4837b2e65909c09ca01babe3df.zip
major target cleanup. it is now possible to have subtargets that can override many target settings, including arch - merge adm5120, adm5120eb. target profiles still need to be adapted for subtargets
SVN-Revision: 8694
Diffstat (limited to 'target/linux/etrax/Makefile')
-rw-r--r--target/linux/etrax/Makefile15
1 files changed, 7 insertions, 8 deletions
diff --git a/target/linux/etrax/Makefile b/target/linux/etrax/Makefile
index 7c9b76fa65..c837550062 100644
--- a/target/linux/etrax/Makefile
+++ b/target/linux/etrax/Makefile
@@ -12,7 +12,10 @@ BOARDNAME:=Foxboard (ETRAX 100LX)
FEATURES:=squashfs jffs2
LINUX_VERSION:=2.6.19.2
-include $(INCLUDE_DIR)/kernel-build.mk
+include $(INCLUDE_DIR)/target.mk
+
+KERNELNAME:="zImage"
+DEFAULT_PACKAGES += foxboard-utils
define Target/Description
Build fimware images for the FOXBOARD made by acmesystems.it
@@ -31,14 +34,10 @@ define Kernel/Prepare
$(call Kernel/Prepare/Fox)
endef
-DEFAULT_PACKAGES += foxboard-utils
+#include the profiles
+-include profiles/*.mk
+$(eval $(call BuildTarget))
$(eval $(call RequireCommand,/usr/local/cris/gcc-cris, \
Please install the binary cris toolchain. \
))
-
-#include the profiles
--include profiles/*.mk
-
-KERNELNAME:="zImage"
-$(eval $(call BuildKernel))