aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/etrax-2.6/patches/generic_2.6/010-disable_old_squashfs_compatibility.patch
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2007-06-02 00:46:02 +0000
committerJohn Crispin <john@openwrt.org>2007-06-02 00:46:02 +0000
commite19eb3d8286ad66f455721f8b7f8260bce5e4016 (patch)
tree37c13b9c5ec72323b4ed9f1757aa7055b5013226 /target/linux/etrax-2.6/patches/generic_2.6/010-disable_old_squashfs_compatibility.patch
parenta1ddc8ab7d95ffb1f50b13c93a90e6e9fda9a591 (diff)
downloadupstream-e19eb3d8286ad66f455721f8b7f8260bce5e4016.tar.gz
upstream-e19eb3d8286ad66f455721f8b7f8260bce5e4016.tar.bz2
upstream-e19eb3d8286ad66f455721f8b7f8260bce5e4016.zip
add initial support for the crisarchitecture used on foxboards to openwrt
SVN-Revision: 7439
Diffstat (limited to 'target/linux/etrax-2.6/patches/generic_2.6/010-disable_old_squashfs_compatibility.patch')
-rw-r--r--target/linux/etrax-2.6/patches/generic_2.6/010-disable_old_squashfs_compatibility.patch21
1 files changed, 21 insertions, 0 deletions
diff --git a/target/linux/etrax-2.6/patches/generic_2.6/010-disable_old_squashfs_compatibility.patch b/target/linux/etrax-2.6/patches/generic_2.6/010-disable_old_squashfs_compatibility.patch
new file mode 100644
index 0000000000..4d556a4133
--- /dev/null
+++ b/target/linux/etrax-2.6/patches/generic_2.6/010-disable_old_squashfs_compatibility.patch
@@ -0,0 +1,21 @@
+diff -urN linux-2.6.19.old/fs/squashfs/Makefile linux-2.6.19.dev/fs/squashfs/Makefile
+--- linux-2.6.19.old/fs/squashfs/Makefile 2006-12-14 03:13:22.000000000 +0100
++++ linux-2.6.19.dev/fs/squashfs/Makefile 2006-12-14 03:13:31.000000000 +0100
+@@ -4,4 +4,3 @@
+
+ obj-$(CONFIG_SQUASHFS) += squashfs.o
+ squashfs-y += inode.o
+-squashfs-y += squashfs2_0.o
+diff -urN linux-2.6.19.old/fs/squashfs/squashfs.h linux-2.6.19.dev/fs/squashfs/squashfs.h
+--- linux-2.6.19.old/fs/squashfs/squashfs.h 2006-12-14 03:13:20.000000000 +0100
++++ linux-2.6.19.dev/fs/squashfs/squashfs.h 2006-12-14 03:13:31.000000000 +0100
+@@ -24,6 +24,9 @@
+ #ifdef CONFIG_SQUASHFS_1_0_COMPATIBILITY
+ #undef CONFIG_SQUASHFS_1_0_COMPATIBILITY
+ #endif
++#ifdef CONFIG_SQUASHFS_2_0_COMPATIBILITY
++#undef CONFIG_SQUASHFS_2_0_COMPATIBILITY
++#endif
+
+ #ifdef SQUASHFS_TRACE
+ #define TRACE(s, args...) printk(KERN_NOTICE "SQUASHFS: "s, ## args)