aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/etrax-2.6/image/e100boot/src/sbl/configure.in
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2007-06-02 00:46:02 +0000
committerJohn Crispin <john@openwrt.org>2007-06-02 00:46:02 +0000
commite19eb3d8286ad66f455721f8b7f8260bce5e4016 (patch)
tree37c13b9c5ec72323b4ed9f1757aa7055b5013226 /target/linux/etrax-2.6/image/e100boot/src/sbl/configure.in
parenta1ddc8ab7d95ffb1f50b13c93a90e6e9fda9a591 (diff)
downloadupstream-e19eb3d8286ad66f455721f8b7f8260bce5e4016.tar.gz
upstream-e19eb3d8286ad66f455721f8b7f8260bce5e4016.tar.bz2
upstream-e19eb3d8286ad66f455721f8b7f8260bce5e4016.zip
add initial support for the crisarchitecture used on foxboards to openwrt
SVN-Revision: 7439
Diffstat (limited to 'target/linux/etrax-2.6/image/e100boot/src/sbl/configure.in')
-rw-r--r--target/linux/etrax-2.6/image/e100boot/src/sbl/configure.in19
1 files changed, 19 insertions, 0 deletions
diff --git a/target/linux/etrax-2.6/image/e100boot/src/sbl/configure.in b/target/linux/etrax-2.6/image/e100boot/src/sbl/configure.in
new file mode 100644
index 0000000000..24e161c50d
--- /dev/null
+++ b/target/linux/etrax-2.6/image/e100boot/src/sbl/configure.in
@@ -0,0 +1,19 @@
+dnl Process this file with autoconf to produce a configure script.
+AC_INIT(common.c)
+AC_CONFIG_HEADER(conf.h)
+
+dnl Checks for programs.
+AC_PROG_CC
+
+dnl Checks for libraries.
+AC_CHECK_LIB(pcap, pcap_open_live)
+
+dnl Checks for header files.
+AC_HEADER_STDC
+AC_CHECK_HEADERS(termios.h sys/ioctl.h net/if.h netinet/in.h netinet/in_systm.h netinet/ip.h netinet/udp.h netinet/tcp.h netdb.h arpa/inet.h sys/socket.h fcntl.h linux/if_ether.h signal.h string.h stdlib.h stdio.h sys/time.h unistd.h sys/stat.h sys/types.h errno.h linux/sockios.h ctype.h sys/socket.h pcap/pcap.h)
+
+dnl Check for typedefs, structures, and compiler characteristics.
+AC_HEADER_TIME
+
+dnl Checks for library functions.
+AC_OUTPUT(Makefile)