aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/etrax-2.6/image/e100boot/src/doc/Makefile
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2007-06-02 00:46:02 +0000
committerJohn Crispin <john@openwrt.org>2007-06-02 00:46:02 +0000
commite19eb3d8286ad66f455721f8b7f8260bce5e4016 (patch)
tree37c13b9c5ec72323b4ed9f1757aa7055b5013226 /target/linux/etrax-2.6/image/e100boot/src/doc/Makefile
parenta1ddc8ab7d95ffb1f50b13c93a90e6e9fda9a591 (diff)
downloadupstream-e19eb3d8286ad66f455721f8b7f8260bce5e4016.tar.gz
upstream-e19eb3d8286ad66f455721f8b7f8260bce5e4016.tar.bz2
upstream-e19eb3d8286ad66f455721f8b7f8260bce5e4016.zip
add initial support for the crisarchitecture used on foxboards to openwrt
SVN-Revision: 7439
Diffstat (limited to 'target/linux/etrax-2.6/image/e100boot/src/doc/Makefile')
-rw-r--r--target/linux/etrax-2.6/image/e100boot/src/doc/Makefile17
1 files changed, 17 insertions, 0 deletions
diff --git a/target/linux/etrax-2.6/image/e100boot/src/doc/Makefile b/target/linux/etrax-2.6/image/e100boot/src/doc/Makefile
new file mode 100644
index 0000000000..df6076b8e2
--- /dev/null
+++ b/target/linux/etrax-2.6/image/e100boot/src/doc/Makefile
@@ -0,0 +1,17 @@
+OBJS=e100boot.1 e100boot.html
+
+all: $(OBJS)
+
+%.1: %.pod
+ pod2man $< > $@
+
+%.html: %.pod
+ pod2html $< > $@
+ @rm -f pod2htmd.x~~ pod2htmi.x~~
+
+clean:
+ rm -f *cache *~
+
+# The 'clean' doesn't remove the generated documentation as we want
+# them in the distribution.
+