aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ep93xx
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2013-06-27 19:58:31 +0000
committerFlorian Fainelli <florian@openwrt.org>2013-06-27 19:58:31 +0000
commit704e2ed39d4e157d0c24d4dc3a3078cbacc6505c (patch)
treeffba1790b89941519ddb5acc2bf8f55df6b65529 /target/linux/ep93xx
parent5431c1983b51e4f69db63f5d5c94b2ed157e5374 (diff)
downloadupstream-704e2ed39d4e157d0c24d4dc3a3078cbacc6505c.tar.gz
upstream-704e2ed39d4e157d0c24d4dc3a3078cbacc6505c.tar.bz2
upstream-704e2ed39d4e157d0c24d4dc3a3078cbacc6505c.zip
targets: prepare for supporting normal and initramfs images
In order to support both normal images and initramfs, ensure that each target sets KERNELNAME properly so that the generic kernel building code can copy the corresponding files over $(KDIR) with the appropriate extension. Update the various paths to the kernel and wrapper images from $(LINUX_DIR)/arch/$(ARCH)/boot/$(foo) to $(KDIR)/$(foo). Signed-off-by: Florian Fainelli <florian@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@37049 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/ep93xx')
-rw-r--r--target/linux/ep93xx/image/Makefile16
1 files changed, 3 insertions, 13 deletions
diff --git a/target/linux/ep93xx/image/Makefile b/target/linux/ep93xx/image/Makefile
index f4064e1bbe..0d5a289e69 100644
--- a/target/linux/ep93xx/image/Makefile
+++ b/target/linux/ep93xx/image/Makefile
@@ -13,22 +13,12 @@ fs_all:=all
fs_4k:=4k
fs_64k:=64k
fs_128k:=128k
-ifeq ($(CONFIG_TARGET_ROOTFS_INITRAMFS),y)
- fs_squash:=initramfs
- fs_all:=initramfs
- fs_4k:=initramfs
- fs_64k:=initramfs
- fs_128k:=initramfs
- UIMAGE:=$(BIN_DIR)/$(IMG_PREFIX)-uImage-initramfs
-endif
-
-
-define Image/Prepare
- cp $(LINUX_DIR)/arch/arm/boot/uImage $(KDIR)/uImage
-endef
define Image/BuildKernel
cp $(KDIR)/uImage $(UIMAGE)
+ifeq ($(CONFIG_TARGET_ROOTFS_INITRAMFS),y)
+ cp $(KDIR)/uImage-initramfs $(UIMAGE)-initramfs
+endif
endef
define Image/Build/jffs2-64k