aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ep93xx
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2012-07-24 19:43:35 +0000
committerFlorian Fainelli <florian@openwrt.org>2012-07-24 19:43:35 +0000
commit587f85ac2018295a078c6d27255c66bf624b8897 (patch)
treeb82d9500816d8b28442ba57c30efe78248817b84 /target/linux/ep93xx
parent5915c85d809b87558c520ac297251a1b04ac377f (diff)
downloadupstream-587f85ac2018295a078c6d27255c66bf624b8897.tar.gz
upstream-587f85ac2018295a078c6d27255c66bf624b8897.tar.bz2
upstream-587f85ac2018295a078c6d27255c66bf624b8897.zip
package ep93xx framebuffer
SVN-Revision: 32807
Diffstat (limited to 'target/linux/ep93xx')
-rw-r--r--target/linux/ep93xx/config-3.39
-rw-r--r--target/linux/ep93xx/modules.mk15
2 files changed, 15 insertions, 9 deletions
diff --git a/target/linux/ep93xx/config-3.3 b/target/linux/ep93xx/config-3.3
index c196e53dab..1175a40e89 100644
--- a/target/linux/ep93xx/config-3.3
+++ b/target/linux/ep93xx/config-3.3
@@ -59,15 +59,6 @@ CONFIG_EP93XX_SDCE0_PHYS_OFFSET=y
# CONFIG_EP93XX_SDCE3_ASYNC_PHYS_OFFSET is not set
# CONFIG_EP93XX_SDCE3_SYNC_PHYS_OFFSET is not set
CONFIG_EP93XX_WATCHDOG=y
-CONFIG_FB=y
-# CONFIG_FB_ARMCLCD is not set
-CONFIG_FB_CFB_COPYAREA=y
-CONFIG_FB_CFB_FILLRECT=y
-CONFIG_FB_CFB_IMAGEBLIT=y
-CONFIG_FB_EP93XX=y
-# CONFIG_FB_SM7XX is not set
-# CONFIG_FB_WMT_GE_ROPS is not set
-# CONFIG_FIRMWARE_EDID is not set
CONFIG_FONTS=y
# CONFIG_FONT_10x18 is not set
# CONFIG_FONT_6x11 is not set
diff --git a/target/linux/ep93xx/modules.mk b/target/linux/ep93xx/modules.mk
index 8b7060ffc7..b8fc3067ce 100644
--- a/target/linux/ep93xx/modules.mk
+++ b/target/linux/ep93xx/modules.mk
@@ -5,6 +5,21 @@
# See /LICENSE for more information.
#
+define KernelPackage/fb-ep93xx
+ SUBMENU:=$(VIDEO_MENU)
+ TITLE:=EP93xx framebuffer support
+ DEPENDS:=@TARGET_ep93xx +kmod-fb
+ KCONFIG:=CONFIG_FB_EP93XX
+ FILES:=$(LINUX_DIR)/drivers/video/ep93xx-fb.ko
+ AUTOLOAD:=$(call AutoLoad,51,ep93xx-fb)
+endef
+
+define KernelPackage/fb-ep93xx/description
+ EP93xx framebuffer support
+endef
+
+$(eval $(call KernelPackage,fb-ep93xx))
+
define KernelPackage/input-keyboard-ep93xx
SUBMENU:=$(OTHER_MENU)
TITLE:=EP93xx Matrix Keypad support