aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ep93xx/Makefile
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2009-11-25 23:43:48 +0000
committerFlorian Fainelli <florian@openwrt.org>2009-11-25 23:43:48 +0000
commit1f610dbc331e68c775767f13e09b882046f01797 (patch)
tree4e11bba416827d9797e6dac0e98bafd030a6ef0f /target/linux/ep93xx/Makefile
parent7ee990428e0bb255087b43d9beadfeac8650e9e9 (diff)
downloadupstream-1f610dbc331e68c775767f13e09b882046f01797.tar.gz
upstream-1f610dbc331e68c775767f13e09b882046f01797.tar.bz2
upstream-1f610dbc331e68c775767f13e09b882046f01797.zip
[ep93xx] add support for the Simplemachines Sim.One board
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@18540 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/ep93xx/Makefile')
-rw-r--r--target/linux/ep93xx/Makefile21
1 files changed, 21 insertions, 0 deletions
diff --git a/target/linux/ep93xx/Makefile b/target/linux/ep93xx/Makefile
new file mode 100644
index 0000000000..a43855ed18
--- /dev/null
+++ b/target/linux/ep93xx/Makefile
@@ -0,0 +1,21 @@
+#
+# Copyright (C) 2009 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+
+ARCH:=arm
+BOARD:=ep93xx
+BOARDNAME:=Cirrus Logic EP93xx SoC
+FEATURES:=squashfs jffs2 ext2 tgz
+CFLAGS:=-Os -pipe -march=armv4t -funit-at-a-time
+
+LINUX_VERSION:=2.6.30.9
+
+include $(INCLUDE_DIR)/target.mk
+
+KERNELNAME:="uImage"
+
+$(eval $(call BuildTarget))