aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/coldfire/image
diff options
context:
space:
mode:
authorImre Kaloz <kaloz@openwrt.org>2009-06-21 18:34:07 +0000
committerImre Kaloz <kaloz@openwrt.org>2009-06-21 18:34:07 +0000
commit2004d4165a115806503d31a3d1162e1d3ab3ed6b (patch)
tree079db45f0521d47c1860a9d75019a9b9c390c71a /target/linux/coldfire/image
parent76d86cd4bba8c968475ec9390aa886b8fd6a7adf (diff)
downloadupstream-2004d4165a115806503d31a3d1162e1d3ab3ed6b.tar.gz
upstream-2004d4165a115806503d31a3d1162e1d3ab3ed6b.tar.bz2
upstream-2004d4165a115806503d31a3d1162e1d3ab3ed6b.zip
add preliminary coldfire v4e support
SVN-Revision: 16538
Diffstat (limited to 'target/linux/coldfire/image')
-rw-r--r--target/linux/coldfire/image/Makefile29
1 files changed, 29 insertions, 0 deletions
diff --git a/target/linux/coldfire/image/Makefile b/target/linux/coldfire/image/Makefile
new file mode 100644
index 0000000000..5eb5c2f2f1
--- /dev/null
+++ b/target/linux/coldfire/image/Makefile
@@ -0,0 +1,29 @@
+#
+# Copyright (C) 2009 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+include $(INCLUDE_DIR)/image.mk
+
+JFFS2_BLOCKSIZE=128k
+
+define Image/Prepare
+endef
+
+define Image/BuildKernel
+endef
+
+define Image/Build
+ $(call Image/Build/$(1),$(1))
+endef
+
+define Image/Build/jffs2-128k
+endef
+
+define Image/Build/squashfs
+ $(call prepare_generic_squashfs,$(KDIR)/root.squashfs)
+endef
+
+$(eval $(call BuildImage))