aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/coldfire/image/Makefile
diff options
context:
space:
mode:
authorImre Kaloz <kaloz@openwrt.org>2009-06-21 18:34:07 +0000
committerImre Kaloz <kaloz@openwrt.org>2009-06-21 18:34:07 +0000
commit0609b66c2c388b7ce5536f4c0a1b14bf617685d2 (patch)
tree39c068bde6937766b91ac60f5157e79c1c8a89c1 /target/linux/coldfire/image/Makefile
parentfc6e01ad10f76d4c9273a707b8ffb6eae48236b1 (diff)
downloadupstream-0609b66c2c388b7ce5536f4c0a1b14bf617685d2.tar.gz
upstream-0609b66c2c388b7ce5536f4c0a1b14bf617685d2.tar.bz2
upstream-0609b66c2c388b7ce5536f4c0a1b14bf617685d2.zip
add preliminary coldfire v4e support
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@16538 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/coldfire/image/Makefile')
-rw-r--r--target/linux/coldfire/image/Makefile29
1 files changed, 29 insertions, 0 deletions
diff --git a/target/linux/coldfire/image/Makefile b/target/linux/coldfire/image/Makefile
new file mode 100644
index 0000000000..5eb5c2f2f1
--- /dev/null
+++ b/target/linux/coldfire/image/Makefile
@@ -0,0 +1,29 @@
+#
+# Copyright (C) 2009 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+include $(INCLUDE_DIR)/image.mk
+
+JFFS2_BLOCKSIZE=128k
+
+define Image/Prepare
+endef
+
+define Image/BuildKernel
+endef
+
+define Image/Build
+ $(call Image/Build/$(1),$(1))
+endef
+
+define Image/Build/jffs2-128k
+endef
+
+define Image/Build/squashfs
+ $(call prepare_generic_squashfs,$(KDIR)/root.squashfs)
+endef
+
+$(eval $(call BuildImage))