aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/cns3xxx/patches-4.9/070-i2c_support.patch
diff options
context:
space:
mode:
authorKoen Vandeputte <koen.vandeputte@ncentric.com>2017-02-07 16:19:18 +0100
committerFelix Fietkau <nbd@nbd.name>2017-02-10 11:05:57 +0100
commit1db4135e32e03c0131301ed46d906a2bf8f08c9b (patch)
treef1da4a38a5ee6d7337843d9528f7e21fa61a006f /target/linux/cns3xxx/patches-4.9/070-i2c_support.patch
parentb96566aad4340c5b790bdaea0514885857ea84bf (diff)
downloadupstream-1db4135e32e03c0131301ed46d906a2bf8f08c9b.tar.gz
upstream-1db4135e32e03c0131301ed46d906a2bf8f08c9b.tar.bz2
upstream-1db4135e32e03c0131301ed46d906a2bf8f08c9b.zip
cns3xxx: add preliminary 4.9 support
Adds preliminary kernel 4.9 support for this target. - Refreshed/Updated all patches Added 3 new patches: - 093 --> Add virtual PCI MMIO mapping - 230 --> Remove deprecated code - 240 --> Rework AT24 eeprom code to use the new NVMEM API Compiled & tested on cns3xxx (gw2388) Signed-off-by: Koen Vandeputte <koen.vandeputte@ncentric.com>
Diffstat (limited to 'target/linux/cns3xxx/patches-4.9/070-i2c_support.patch')
-rw-r--r--target/linux/cns3xxx/patches-4.9/070-i2c_support.patch31
1 files changed, 31 insertions, 0 deletions
diff --git a/target/linux/cns3xxx/patches-4.9/070-i2c_support.patch b/target/linux/cns3xxx/patches-4.9/070-i2c_support.patch
new file mode 100644
index 0000000000..dc64da1e07
--- /dev/null
+++ b/target/linux/cns3xxx/patches-4.9/070-i2c_support.patch
@@ -0,0 +1,31 @@
+--- a/drivers/i2c/busses/Kconfig
++++ b/drivers/i2c/busses/Kconfig
+@@ -441,6 +441,18 @@ config I2C_CBUS_GPIO
+ This driver can also be built as a module. If so, the module
+ will be called i2c-cbus-gpio.
+
++config I2C_CNS3XXX
++ tristate "Cavium CNS3xxx I2C driver"
++ depends on ARCH_CNS3XXX
++ help
++ Support for Cavium CNS3xxx I2C controller driver.
++
++ This driver can also be built as a module. If so, the module
++ will be called i2c-cns3xxx.
++
++ Please note that this driver might be needed to bring up other
++ devices such as Cavium CNS3xxx Ethernet.
++
+ config I2C_CPM
+ tristate "Freescale CPM1 or CPM2 (MPC8xx/826x)"
+ depends on CPM1 || CPM2
+--- a/drivers/i2c/busses/Makefile
++++ b/drivers/i2c/busses/Makefile
+@@ -114,6 +114,7 @@ obj-$(CONFIG_I2C_VIPERBOARD) += i2c-vipe
+ obj-$(CONFIG_I2C_ACORN) += i2c-acorn.o
+ obj-$(CONFIG_I2C_BCM_KONA) += i2c-bcm-kona.o
+ obj-$(CONFIG_I2C_BRCMSTB) += i2c-brcmstb.o
++obj-$(CONFIG_I2C_CNS3XXX) += i2c-cns3xxx.o
+ obj-$(CONFIG_I2C_CROS_EC_TUNNEL) += i2c-cros-ec-tunnel.o
+ obj-$(CONFIG_I2C_ELEKTOR) += i2c-elektor.o
+ obj-$(CONFIG_I2C_OPAL) += i2c-opal.o