aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/cns3xxx/patches-4.4/040-fiq_support.patch
diff options
context:
space:
mode:
authorKoen Vandeputte <koen.vandeputte@ncentric.com>2017-02-08 09:44:14 +0100
committerFelix Fietkau <nbd@nbd.name>2017-04-12 12:12:49 +0200
commit2611f67423a2be18f6fe825e6aef3f1cc956eb65 (patch)
tree004857e175b10e70887c8dec1284f31eb50ade5b /target/linux/cns3xxx/patches-4.4/040-fiq_support.patch
parentffd055d5bbc1a223c80eb5bbc03a6465d0ac0bb4 (diff)
downloadupstream-2611f67423a2be18f6fe825e6aef3f1cc956eb65.tar.gz
upstream-2611f67423a2be18f6fe825e6aef3f1cc956eb65.tar.bz2
upstream-2611f67423a2be18f6fe825e6aef3f1cc956eb65.zip
cns3xxx: remove linux 4.4 support
Signed-off-by: Koen Vandeputte <koen.vandeputte@ncentric.com>
Diffstat (limited to 'target/linux/cns3xxx/patches-4.4/040-fiq_support.patch')
-rw-r--r--target/linux/cns3xxx/patches-4.4/040-fiq_support.patch40
1 files changed, 0 insertions, 40 deletions
diff --git a/target/linux/cns3xxx/patches-4.4/040-fiq_support.patch b/target/linux/cns3xxx/patches-4.4/040-fiq_support.patch
deleted file mode 100644
index 3c0d23bd77..0000000000
--- a/target/linux/cns3xxx/patches-4.4/040-fiq_support.patch
+++ /dev/null
@@ -1,40 +0,0 @@
---- a/arch/arm/mach-cns3xxx/Kconfig
-+++ b/arch/arm/mach-cns3xxx/Kconfig
-@@ -5,6 +5,7 @@ menuconfig ARCH_CNS3XXX
- select HAVE_ARM_SCU if SMP
- select HAVE_ARM_TWD
- select HAVE_SMP
-+ select FIQ
- help
- Support for Cavium Networks CNS3XXX platform.
-
---- a/arch/arm/mach-cns3xxx/Makefile
-+++ b/arch/arm/mach-cns3xxx/Makefile
-@@ -5,5 +5,5 @@ cns3xxx-y += core.o pm.o
- cns3xxx-$(CONFIG_ATAGS) += devices.o
- cns3xxx-$(CONFIG_PCI) += pcie.o
- cns3xxx-$(CONFIG_MACH_CNS3420VB) += cns3420vb.o
--cns3xxx-$(CONFIG_SMP) += platsmp.o headsmp.o
-+cns3xxx-$(CONFIG_SMP) += platsmp.o headsmp.o cns3xxx_fiq.o
- cns3xxx-$(CONFIG_HOTPLUG_CPU) += hotplug.o
---- a/arch/arm/mach-cns3xxx/cns3xxx.h
-+++ b/arch/arm/mach-cns3xxx/cns3xxx.h
-@@ -267,6 +267,7 @@
- #define MISC_PCIE_INT_MASK(x) MISC_MEM_MAP(0x978 + (x) * 0x100)
- #define MISC_PCIE_INT_STATUS(x) MISC_MEM_MAP(0x97C + (x) * 0x100)
-
-+#define MISC_FIQ_CPU(x) MISC_MEM_MAP(0xA58 - (x) * 0x4)
- /*
- * Power management and clock control
- */
---- a/arch/arm/mm/Kconfig
-+++ b/arch/arm/mm/Kconfig
-@@ -849,7 +849,7 @@ config VDSO
-
- config DMA_CACHE_RWFO
- bool "Enable read/write for ownership DMA cache maintenance"
-- depends on CPU_V6K && SMP
-+ depends on CPU_V6K && SMP && !ARCH_CNS3XXX
- default y
- help
- The Snoop Control Unit on ARM11MPCore does not detect the