aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/cns3xxx/patches-3.3/075-spi_support.patch
diff options
context:
space:
mode:
authorImre Kaloz <kaloz@openwrt.org>2012-11-12 09:18:00 +0000
committerImre Kaloz <kaloz@openwrt.org>2012-11-12 09:18:00 +0000
commit29fb5ae7927dae81d76acd79ee8c3f6bee5fd099 (patch)
tree97b650ca1cf4ee2701cbd835e0fcf87dc20e0b8a /target/linux/cns3xxx/patches-3.3/075-spi_support.patch
parent7a955260a68b62c4c769b79bb22c545019c98d3d (diff)
downloadupstream-29fb5ae7927dae81d76acd79ee8c3f6bee5fd099.tar.gz
upstream-29fb5ae7927dae81d76acd79ee8c3f6bee5fd099.tar.bz2
upstream-29fb5ae7927dae81d76acd79ee8c3f6bee5fd099.zip
[cns3xxx]: reorder, rename and refresh patches
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@34169 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/cns3xxx/patches-3.3/075-spi_support.patch')
-rw-r--r--target/linux/cns3xxx/patches-3.3/075-spi_support.patch41
1 files changed, 41 insertions, 0 deletions
diff --git a/target/linux/cns3xxx/patches-3.3/075-spi_support.patch b/target/linux/cns3xxx/patches-3.3/075-spi_support.patch
new file mode 100644
index 0000000000..0434c520e2
--- /dev/null
+++ b/target/linux/cns3xxx/patches-3.3/075-spi_support.patch
@@ -0,0 +1,41 @@
+--- a/drivers/spi/Kconfig
++++ b/drivers/spi/Kconfig
+@@ -117,6 +117,13 @@ config SPI_BUTTERFLY
+ inexpensive battery powered microcontroller evaluation board.
+ This same cable can be used to flash new firmware.
+
++config SPI_CNS3XXX
++ tristate "CNS3XXX SPI controller"
++ depends on ARCH_CNS3XXX && SPI_MASTER
++ select SPI_BITBANG
++ help
++ This enables using the CNS3XXX SPI controller in master mode.
++
+ config SPI_COLDFIRE_QSPI
+ tristate "Freescale Coldfire QSPI controller"
+ depends on (M520x || M523x || M5249 || M527x || M528x || M532x)
+--- a/drivers/spi/Makefile
++++ b/drivers/spi/Makefile
+@@ -18,6 +18,7 @@ obj-$(CONFIG_SPI_BFIN) += spi-bfin5xx.
+ obj-$(CONFIG_SPI_BFIN_SPORT) += spi-bfin-sport.o
+ obj-$(CONFIG_SPI_BITBANG) += spi-bitbang.o
+ obj-$(CONFIG_SPI_BUTTERFLY) += spi-butterfly.o
++obj-$(CONFIG_SPI_CNS3XXX) += spi-cns3xxx.o
+ obj-$(CONFIG_SPI_COLDFIRE_QSPI) += spi-coldfire-qspi.o
+ obj-$(CONFIG_SPI_DAVINCI) += spi-davinci.o
+ obj-$(CONFIG_SPI_DESIGNWARE) += spi-dw.o
+--- a/drivers/spi/spi-bitbang.c
++++ b/drivers/spi/spi-bitbang.c
+@@ -330,6 +330,12 @@ static void bitbang_work(struct work_str
+ */
+ if (!m->is_dma_mapped)
+ t->rx_dma = t->tx_dma = 0;
++
++ if (t->transfer_list.next == &m->transfers)
++ t->last_in_message_list = 1;
++ else
++ t->last_in_message_list = 0;
++
+ status = bitbang->txrx_bufs(spi, t);
+ }
+ if (status > 0)