aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/cns3xxx/patches-3.14/070-i2c_support.patch
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2015-03-16 07:40:41 +0000
committerJohn Crispin <john@openwrt.org>2015-03-16 07:40:41 +0000
commit518d9fd2a0bef9b05c48cebb061b6b462961b3c7 (patch)
treeef1ba97d3cf4335a441084d2dcec23317974463e /target/linux/cns3xxx/patches-3.14/070-i2c_support.patch
parent43c66cb43416a6cac063a2b2213b79603dcc0dbf (diff)
downloadupstream-518d9fd2a0bef9b05c48cebb061b6b462961b3c7.tar.gz
upstream-518d9fd2a0bef9b05c48cebb061b6b462961b3c7.tar.bz2
upstream-518d9fd2a0bef9b05c48cebb061b6b462961b3c7.zip
cns3xxx: drop 3.14 support
Signed-off-by: John Crispin <blogic@openwrt.org> SVN-Revision: 44817
Diffstat (limited to 'target/linux/cns3xxx/patches-3.14/070-i2c_support.patch')
-rw-r--r--target/linux/cns3xxx/patches-3.14/070-i2c_support.patch31
1 files changed, 0 insertions, 31 deletions
diff --git a/target/linux/cns3xxx/patches-3.14/070-i2c_support.patch b/target/linux/cns3xxx/patches-3.14/070-i2c_support.patch
deleted file mode 100644
index 1b2a7d8574..0000000000
--- a/target/linux/cns3xxx/patches-3.14/070-i2c_support.patch
+++ /dev/null
@@ -1,31 +0,0 @@
---- a/drivers/i2c/busses/Kconfig
-+++ b/drivers/i2c/busses/Kconfig
-@@ -386,6 +386,18 @@ config I2C_CBUS_GPIO
- This driver can also be built as a module. If so, the module
- will be called i2c-cbus-gpio.
-
-+config I2C_CNS3XXX
-+ tristate "Cavium CNS3xxx I2C driver"
-+ depends on ARCH_CNS3XXX
-+ help
-+ Support for Cavium CNS3xxx I2C controller driver.
-+
-+ This driver can also be built as a module. If so, the module
-+ will be called i2c-cns3xxx.
-+
-+ Please note that this driver might be needed to bring up other
-+ devices such as Cavium CNS3xxx Ethernet.
-+
- config I2C_CPM
- tristate "Freescale CPM1 or CPM2 (MPC8xx/826x)"
- depends on CPM1 || CPM2
---- a/drivers/i2c/busses/Makefile
-+++ b/drivers/i2c/busses/Makefile
-@@ -95,6 +95,7 @@ obj-$(CONFIG_I2C_BCM_KONA) += i2c-bcm-ko
- obj-$(CONFIG_I2C_ELEKTOR) += i2c-elektor.o
- obj-$(CONFIG_I2C_PCA_ISA) += i2c-pca-isa.o
- obj-$(CONFIG_I2C_SIBYTE) += i2c-sibyte.o
-+obj-$(CONFIG_I2C_CNS3XXX) += i2c-cns3xxx.o
- obj-$(CONFIG_SCx200_ACB) += scx200_acb.o
- obj-$(CONFIG_SCx200_I2C) += scx200_i2c.o
-