aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/cns3xxx/patches-3.14/025-smp_support.patch
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2015-03-16 07:40:41 +0000
committerJohn Crispin <blogic@openwrt.org>2015-03-16 07:40:41 +0000
commit102d657c2aabbf221542ece910bfd95a61c0158d (patch)
tree4ffa7a30362aff24cd653702baf2a696f0b9a99e /target/linux/cns3xxx/patches-3.14/025-smp_support.patch
parent42d874818fa7e90cbc2827125f4419960c6323c4 (diff)
downloadupstream-102d657c2aabbf221542ece910bfd95a61c0158d.tar.gz
upstream-102d657c2aabbf221542ece910bfd95a61c0158d.tar.bz2
upstream-102d657c2aabbf221542ece910bfd95a61c0158d.zip
cns3xxx: drop 3.14 support
Signed-off-by: John Crispin <blogic@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@44817 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/cns3xxx/patches-3.14/025-smp_support.patch')
-rw-r--r--target/linux/cns3xxx/patches-3.14/025-smp_support.patch30
1 files changed, 0 insertions, 30 deletions
diff --git a/target/linux/cns3xxx/patches-3.14/025-smp_support.patch b/target/linux/cns3xxx/patches-3.14/025-smp_support.patch
deleted file mode 100644
index d4ae6f4b9d..0000000000
--- a/target/linux/cns3xxx/patches-3.14/025-smp_support.patch
+++ /dev/null
@@ -1,30 +0,0 @@
---- a/arch/arm/mach-cns3xxx/Makefile
-+++ b/arch/arm/mach-cns3xxx/Makefile
-@@ -5,3 +5,5 @@ cns3xxx-y += core.o pm.o
- cns3xxx-$(CONFIG_ATAGS) += devices.o
- cns3xxx-$(CONFIG_PCI) += pcie.o
- cns3xxx-$(CONFIG_MACH_CNS3420VB) += cns3420vb.o
-+cns3xxx-$(CONFIG_SMP) += platsmp.o headsmp.o
-+cns3xxx-$(CONFIG_HOTPLUG_CPU) += hotplug.o
---- a/arch/arm/mach-cns3xxx/Kconfig
-+++ b/arch/arm/mach-cns3xxx/Kconfig
-@@ -6,6 +6,9 @@ config ARCH_CNS3XXX
- select MIGHT_HAVE_CACHE_L2X0
- select MIGHT_HAVE_PCI
- select PCI_DOMAINS if PCI
-+ select HAVE_ARM_SCU if SMP
-+ select HAVE_ARM_TWD if LOCAL_TIMERS
-+ select HAVE_SMP
- help
- Support for Cavium Networks CNS3XXX platform.
-
---- a/arch/arm/mach-cns3xxx/core.h
-+++ b/arch/arm/mach-cns3xxx/core.h
-@@ -13,6 +13,7 @@
-
- #include <linux/reboot.h>
-
-+extern struct smp_operations cns3xxx_smp_ops;
- extern void cns3xxx_timer_init(void);
-
- #ifdef CONFIG_CACHE_L2X0