aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/cns3xxx/files/drivers/usb/dwc/Makefile
diff options
context:
space:
mode:
authorLuka Perkov <luka@openwrt.org>2012-11-11 20:03:58 +0000
committerLuka Perkov <luka@openwrt.org>2012-11-11 20:03:58 +0000
commit37b69da0ca297e3f6dc61320cb1f88f3de348b34 (patch)
tree570397989f27e1a242d600cc148d73d40d1c065f /target/linux/cns3xxx/files/drivers/usb/dwc/Makefile
parent80a28570bd1c0e616645e6f93765e083909968bf (diff)
downloadupstream-37b69da0ca297e3f6dc61320cb1f88f3de348b34.tar.gz
upstream-37b69da0ca297e3f6dc61320cb1f88f3de348b34.tar.bz2
upstream-37b69da0ca297e3f6dc61320cb1f88f3de348b34.zip
cns3xxx: convert dwc_otg patches to files
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@34162 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/cns3xxx/files/drivers/usb/dwc/Makefile')
-rw-r--r--target/linux/cns3xxx/files/drivers/usb/dwc/Makefile26
1 files changed, 26 insertions, 0 deletions
diff --git a/target/linux/cns3xxx/files/drivers/usb/dwc/Makefile b/target/linux/cns3xxx/files/drivers/usb/dwc/Makefile
new file mode 100644
index 0000000000..58f3db75c7
--- /dev/null
+++ b/target/linux/cns3xxx/files/drivers/usb/dwc/Makefile
@@ -0,0 +1,26 @@
+#
+# Makefile for DWC_otg Highspeed USB controller driver
+#
+
+EXTRA_CFLAGS += -DDWC_HS_ELECT_TST
+#EXTRA_CFLAGS += -Dlinux -DDWC_HS_ELECT_TST
+#EXTRA_CFLAGS += -DDWC_EN_ISOC
+
+ifneq ($(CONFIG_DWC_HOST_ONLY),)
+EXTRA_CFLAGS += -DDWC_HOST_ONLY
+endif
+
+ifneq ($(CONFIG_DWC_DEVICE_ONLY),)
+EXTRA_CFLAGS += -DDWC_DEVICE_ONLY
+endif
+
+ifneq ($(CONFIG_DWC_DEBUG),)
+EXTRA_CFLAGS += -DDEBUG
+endif
+
+obj-$(CONFIG_USB_DWC_OTG) := dwc_otg.o
+
+dwc_otg-objs := otg_driver.o otg_attr.o
+dwc_otg-objs += otg_cil.o otg_cil_intr.o
+dwc_otg-objs += otg_pcd.o otg_pcd_intr.o
+dwc_otg-objs += otg_hcd.o otg_hcd_intr.o otg_hcd_queue.o