aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/cns21xx/image/Makefile
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2012-03-18 12:07:56 +0000
committerGabor Juhos <juhosg@openwrt.org>2012-03-18 12:07:56 +0000
commita7ccf18c14ae5725d21072093c92e266efe09b83 (patch)
treefc38852d9c9974d47affe9483c934de81653d2bf /target/linux/cns21xx/image/Makefile
parenteba873061b56e253fb7293c48a5f8ed370d3212d (diff)
downloadupstream-a7ccf18c14ae5725d21072093c92e266efe09b83.tar.gz
upstream-a7ccf18c14ae5725d21072093c92e266efe09b83.tar.bz2
upstream-a7ccf18c14ae5725d21072093c92e266efe09b83.zip
cns21xx: build uImage for the NS-K330
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@30974 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/cns21xx/image/Makefile')
-rw-r--r--target/linux/cns21xx/image/Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/target/linux/cns21xx/image/Makefile b/target/linux/cns21xx/image/Makefile
index 9b1e216db6..711a85e8f5 100644
--- a/target/linux/cns21xx/image/Makefile
+++ b/target/linux/cns21xx/image/Makefile
@@ -55,12 +55,13 @@ define Image/Prepare
# NSB3AST : mach id 2917 (0xb65)
$(call prepare_zimage,nsb3ast,0b,65)
# NS-K330 : mach id 3108 (0xc24)
- $(call prepare_zimage,ns-k330,0c,24)
+ $(call prepare_uimage,ns-k330,0c,24)
endef
define Image/BuildKernel
cat $(KDIR)/$(call zimage_name,nsb3ast) > $(BIN_DIR)/$(call zimage_name,nsb3ast)
cat $(KDIR)/$(call zimage_name,ns-k330) > $(BIN_DIR)/$(call zimage_name,ns-k330)
+ cat $(KDIR)/$(call uimage_name,ns-k330) > $(BIN_DIR)/$(call uimage_name,ns-k330)
endef
define Image/Build/Generic
@@ -97,6 +98,7 @@ endef
define Image/Build/NSK330
$(call Image/Build/Generic,$(1),ns-k330,2686976)
+ $(call Image/Build/uImage,$(1),ns-k330,2686976)
endef
define Image/Build/squashfs