aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/cns21xx/Makefile
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2010-12-30 17:19:16 +0000
committerGabor Juhos <juhosg@openwrt.org>2010-12-30 17:19:16 +0000
commit0d46434b606a53fc835cbb70cad4bf03e99f613d (patch)
tree4b78a3202e08ca31ea33039589d221a2e19cbcf7 /target/linux/cns21xx/Makefile
parent6c025a3167120ae374ba45a23d6d9067081cee49 (diff)
downloadupstream-0d46434b606a53fc835cbb70cad4bf03e99f613d.tar.gz
upstream-0d46434b606a53fc835cbb70cad4bf03e99f613d.tar.bz2
upstream-0d46434b606a53fc835cbb70cad4bf03e99f613d.zip
cns21xx: add initial support for the Cavium CNS21xx SoC
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@24859 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/cns21xx/Makefile')
-rw-r--r--target/linux/cns21xx/Makefile27
1 files changed, 27 insertions, 0 deletions
diff --git a/target/linux/cns21xx/Makefile b/target/linux/cns21xx/Makefile
new file mode 100644
index 0000000000..db098e7861
--- /dev/null
+++ b/target/linux/cns21xx/Makefile
@@ -0,0 +1,27 @@
+#
+# Copyright (C) 2010 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+
+ARCH:=arm
+BOARD:=cns21xx
+BOARDNAME:=Cavium Networks CNS21xx
+FEATURES:=squashfs broken
+CFLAGS:=-Os -pipe -march=armv4 -mtune=arm9tdmi -funit-at-a-time
+
+LINUX_VERSION:=2.6.36.2
+
+include $(INCLUDE_DIR)/target.mk
+
+DEFAULT_PACKAGES += \
+ kmod-leds-gpio kmod-input-core kmod-input-gpio-keys \
+ kmod-button-hotplug
+
+define Target/Description
+ Build firmware images for Cavium Networks CNS21XX based boards.
+endef
+
+$(eval $(call BuildTarget))