aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/cavium-octeon/Makefile
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2009-05-06 18:12:49 +0000
committerFlorian Fainelli <florian@openwrt.org>2009-05-06 18:12:49 +0000
commit70f94ae2ab0e5460b817ad7b670f071d904d8bab (patch)
tree89145ffa8eb280689e41008eacbd8057e3ac0dc7 /target/linux/cavium-octeon/Makefile
parent731a0e4791eafdb464c13b02383fae6711e72813 (diff)
downloadupstream-70f94ae2ab0e5460b817ad7b670f071d904d8bab.tar.gz
upstream-70f94ae2ab0e5460b817ad7b670f071d904d8bab.tar.bz2
upstream-70f94ae2ab0e5460b817ad7b670f071d904d8bab.zip
add support for the Cavium Octeon SoC, tested on a Mototech evaluation board
SVN-Revision: 15640
Diffstat (limited to 'target/linux/cavium-octeon/Makefile')
-rw-r--r--target/linux/cavium-octeon/Makefile25
1 files changed, 25 insertions, 0 deletions
diff --git a/target/linux/cavium-octeon/Makefile b/target/linux/cavium-octeon/Makefile
new file mode 100644
index 0000000000..1d5df0093d
--- /dev/null
+++ b/target/linux/cavium-octeon/Makefile
@@ -0,0 +1,25 @@
+#
+# Copyright (C) 2009 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+
+ARCH:=mips
+BOARD:=cavium-octeon
+BOARDNAME:=Cavium Networks Octeon
+FEATURES:=squashfs jffs2
+CFLAGS:=-Os -pipe -funit-at-a-time
+
+LINUX_VERSION:=2.6.29.2
+
+include $(INCLUDE_DIR)/target.mk
+
+DEFAULT_PACKAGES += hostapd-mini
+
+define Target/Description
+ Build firmware images for Cavium Networks Octeon-based boards.
+endef
+
+$(eval $(call BuildTarget))