aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/brcm63xx
diff options
context:
space:
mode:
authorDaniel Gonzalez Cabanelas <dgcbueu@gmail.com>2016-08-29 16:03:33 +0200
committerJonas Gorski <jonas.gorski@gmail.com>2016-11-21 18:40:15 +0100
commitaedca3ce430c0edcf582118d393fe13349fca741 (patch)
treea8bc8bfe78e6992d746d4a405cb172b7dff73ae0 /target/linux/brcm63xx
parent422ba32c71f4389540e2633fcffca326b60f6ddc (diff)
downloadupstream-aedca3ce430c0edcf582118d393fe13349fca741.tar.gz
upstream-aedca3ce430c0edcf582118d393fe13349fca741.tar.bz2
upstream-aedca3ce430c0edcf582118d393fe13349fca741.zip
brcm63xx: Livebox 1: relocate the kernel to fix boot
Fix Image generation for the Livebox 1 - missing "relocate-kernel", wrong "LOADADDR", fix it Signed-off-by: Daniel Gonzalez Cabanelas <dgcbueu@gmail.com> Signed-off-by: Jonas Gorski <jonas.gorski@gmail.com>
Diffstat (limited to 'target/linux/brcm63xx')
-rw-r--r--target/linux/brcm63xx/image/Makefile2
-rw-r--r--target/linux/brcm63xx/image/bcm63xx.mk2
2 files changed, 2 insertions, 2 deletions
diff --git a/target/linux/brcm63xx/image/Makefile b/target/linux/brcm63xx/image/Makefile
index 6e7ca8febb..c9363dda0a 100644
--- a/target/linux/brcm63xx/image/Makefile
+++ b/target/linux/brcm63xx/image/Makefile
@@ -151,7 +151,7 @@ define Build/redboot-bin
$(TOPDIR)/scripts/redboot-script.pl \
-k $(BIN_DIR)/$(REDBOOT_PREFIX)-vmlinux.gz \
-r $(BIN_DIR)/$(REDBOOT_PREFIX)-$(notdir $(IMAGE_ROOTFS)) \
- -a $(strip $(LOADADDR)) -f 0xbe430000 -l 0x7c0000 \
+ -a $(strip $(LOADER_ENTRY)) -f 0xbe430000 -l 0x7c0000 \
-s 0x1000 -t 20 -o $@.redbootscript
dd if="$@.redbootscript" of="$@.redbootscript.padded" bs=4096 conv=sync
cat \
diff --git a/target/linux/brcm63xx/image/bcm63xx.mk b/target/linux/brcm63xx/image/bcm63xx.mk
index af14168b74..34d496e928 100644
--- a/target/linux/brcm63xx/image/bcm63xx.mk
+++ b/target/linux/brcm63xx/image/bcm63xx.mk
@@ -44,7 +44,7 @@ DEVICE_VARS += NETGEAR_BOARD_ID NETGEAR_REGION
define Device/bcm63xx_redboot
FILESYSTEMS := squashfs
- KERNEL := kernel-bin | append-dtb | gzip
+ KERNEL := kernel-bin | append-dtb | relocate-kernel | gzip
KERNEL_INITRAMFS := kernel-bin | append-dtb | lzma | loader-lzma elf
IMAGES := redboot.bin
IMAGE/redboot.bin := redboot-bin