aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/brcm63xx
diff options
context:
space:
mode:
authorJonas Gorski <jogo@openwrt.org>2014-02-22 11:16:38 +0000
committerJonas Gorski <jogo@openwrt.org>2014-02-22 11:16:38 +0000
commit1375b2da00495288b4df36e5b77ef4479a96cf9f (patch)
tree6e9cc528d689e7563ce950ef1a8544e13eaefb92 /target/linux/brcm63xx
parent7c03680aea69104a72283fc5cd5b21c5b4a90775 (diff)
downloadupstream-1375b2da00495288b4df36e5b77ef4479a96cf9f.tar.gz
upstream-1375b2da00495288b4df36e5b77ef4479a96cf9f.tar.bz2
upstream-1375b2da00495288b4df36e5b77ef4479a96cf9f.zip
brcm63xx: add support for Asmax AR 1004g router
Support for Asmax AR 1004g router Signed-off-by: Adrian Feliks <mexit@o2.pl> Patchwork: http://patchwork.openwrt.org/patch/4464/ Signed-off-by: Jonas Gorski <jogo@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@39674 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/brcm63xx')
-rwxr-xr-xtarget/linux/brcm63xx/base-files/etc/uci-defaults/02_network1
-rwxr-xr-xtarget/linux/brcm63xx/base-files/lib/brcm63xx.sh4
-rwxr-xr-xtarget/linux/brcm63xx/image/Makefile2
-rw-r--r--target/linux/brcm63xx/patches-3.10/558-board_AR1004G.patch70
-rw-r--r--target/linux/brcm63xx/patches-3.10/801-ssb_export_fallback_sprom.patch4
5 files changed, 79 insertions, 2 deletions
diff --git a/target/linux/brcm63xx/base-files/etc/uci-defaults/02_network b/target/linux/brcm63xx/base-files/etc/uci-defaults/02_network
index 087bce960d..b4ab46d56b 100755
--- a/target/linux/brcm63xx/base-files/etc/uci-defaults/02_network
+++ b/target/linux/brcm63xx/base-files/etc/uci-defaults/02_network
@@ -28,6 +28,7 @@ SPW500V)
96338W2_E7T |\
96348A-122 |\
96348W3 |\
+AR1004G |\
CPVA642 |\
CT536_CT5621 |\
CT6373-1 |\
diff --git a/target/linux/brcm63xx/base-files/lib/brcm63xx.sh b/target/linux/brcm63xx/base-files/lib/brcm63xx.sh
index afe9624933..1d9b448b75 100755
--- a/target/linux/brcm63xx/base-files/lib/brcm63xx.sh
+++ b/target/linux/brcm63xx/base-files/lib/brcm63xx.sh
@@ -57,6 +57,10 @@ brcm63xx_detect() {
brcm63xx_has_reset_button="true"
ifname=eth1
;;
+ AR1004G)
+ status_led="AR1004G:green:power"
+ brcm63xx_has_reset_button="true"
+ ;;
CVG834G_E15R3921)
status_led="CVG834G:green:power"
ifname=eth0
diff --git a/target/linux/brcm63xx/image/Makefile b/target/linux/brcm63xx/image/Makefile
index e0bcb07d61..ecdcecaaa3 100755
--- a/target/linux/brcm63xx/image/Makefile
+++ b/target/linux/brcm63xx/image/Makefile
@@ -190,6 +190,8 @@ define Image/Build
$(call Image/Build/CFE,$(1),96368MVNgr,6368,96368MVNgr-generic)
$(call Image/Build/CFE,$(1),96368MVWG,6368,96368MVWG-generic)
+ # Asmax AR 1004g
+ $(call Image/Build/CFEFIXUP,$(1),96348GW-10,AR1004G,6348,AR1004G)
# BT Voyager V210_BTR
$(call Image/Build/CFE,$(1),V210_BB,6348,BTV210_BTR,,--layoutver 5)
# BT Voyager V210_ROI, V210_WB
diff --git a/target/linux/brcm63xx/patches-3.10/558-board_AR1004G.patch b/target/linux/brcm63xx/patches-3.10/558-board_AR1004G.patch
new file mode 100644
index 0000000000..4fb76ed29f
--- /dev/null
+++ b/target/linux/brcm63xx/patches-3.10/558-board_AR1004G.patch
@@ -0,0 +1,70 @@
+From: "mexit@o2.pl" <mexit@o2.pl>
+Date: Sun, 24 Nov 2013 21:33:38 +0000
+Subject: [PATCH 4/5] brcm63xx: add support for Asmax AR 1004g router
+
+Support for Asmax AR 1004g router
+
+Signed-off-by: Adrian Feliks <mexit@o2.pl>
+---
+--- a/arch/mips/bcm63xx/boards/board_bcm963xx.c
++++ b/arch/mips/bcm63xx/boards/board_bcm963xx.c
+@@ -2208,6 +2208,51 @@ static struct board_info __initdata boar
+ },
+ };
+
++static struct board_info __initdata board_96348gw_10_AR1004G = {
++ .name = "AR1004G",
++ .expected_cpu_id = 0x6348,
++
++ .has_uart0 = 1,
++ .has_enet1 = 1,
++ .has_pci = 1,
++
++ .enet1 = {
++ .has_phy = 1,
++ .phy_id = 0,
++ .force_speed_100 = 1,
++ .force_duplex_full = 1,
++ },
++
++ .leds = {
++ {
++ .name = "AR1004G:green:inet",
++ .gpio = 3,
++ .active_low = 1,
++ },
++ {
++ .name = "AR1004G:green:power",
++ .gpio = 0,
++ .active_low = 1,
++ },
++ {
++ .name = "AR1004G:red:power",
++ .gpio = 6,
++ .active_low = 1,
++ },
++ },
++
++ .buttons = {
++ {
++ .desc = "reset",
++ .gpio = 33,
++ .active_low = 1,
++ .type = EV_KEY,
++ .code = KEY_RESTART,
++ .debounce_interval = BCM963XX_KEYS_DEBOUNCE_INTERVAL,
++ },
++ },
++};
++
+ #endif
+
+ /*
+@@ -4457,6 +4502,7 @@ static const struct board_info __initcon
+ &board_96348A_122,
+ &board_CPVA502plus,
+ &board_96348W3,
++ &board_96348gw_10_AR1004G,
+ #endif
+
+ #ifdef CONFIG_BCM63XX_CPU_6358
diff --git a/target/linux/brcm63xx/patches-3.10/801-ssb_export_fallback_sprom.patch b/target/linux/brcm63xx/patches-3.10/801-ssb_export_fallback_sprom.patch
index 7ed27a6211..620bf40021 100644
--- a/target/linux/brcm63xx/patches-3.10/801-ssb_export_fallback_sprom.patch
+++ b/target/linux/brcm63xx/patches-3.10/801-ssb_export_fallback_sprom.patch
@@ -8,7 +8,7 @@
#include <linux/spi/spi.h>
#include <linux/spi/spi_gpio.h>
#include <linux/spi/74x164.h>
-@@ -4499,7 +4500,7 @@ static const struct board_info __initcon
+@@ -4545,7 +4546,7 @@ static const struct board_info __initcon
* bcm4318 WLAN work
*/
#ifdef CONFIG_SSB_PCIHOST
@@ -17,7 +17,7 @@
.revision = 0x02,
.board_rev = 0x17,
.country_code = 0x0,
-@@ -4519,6 +4520,7 @@ static struct ssb_sprom bcm63xx_sprom =
+@@ -4565,6 +4566,7 @@ static struct ssb_sprom bcm63xx_sprom =
.boardflags_lo = 0x2848,
.boardflags_hi = 0x0000,
};