aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/brcm63xx/smp/profiles
diff options
context:
space:
mode:
authorJonas Gorski <jogo@openwrt.org>2013-05-02 15:28:31 +0000
committerJonas Gorski <jogo@openwrt.org>2013-05-02 15:28:31 +0000
commit1780aae0a88de1b039db06b0b27b566a9813f76e (patch)
tree57e2c2cf8c74ed149c696894980ea65e1af5617b /target/linux/brcm63xx/smp/profiles
parentdec4629f2753e8fdcc69584be9d326d5a24c1841 (diff)
downloadupstream-1780aae0a88de1b039db06b0b27b566a9813f76e.tar.gz
upstream-1780aae0a88de1b039db06b0b27b566a9813f76e.tar.bz2
upstream-1780aae0a88de1b039db06b0b27b566a9813f76e.zip
bcm63xx: split into two subtargets, generic and SMP
Make SMP a subtarget, since it only supports BCM6362 and BCM6368. Signed-off-by: Jonas Gorski <jogo@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@36527 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/brcm63xx/smp/profiles')
-rw-r--r--target/linux/brcm63xx/smp/profiles/100-Broadcom.mk17
-rw-r--r--target/linux/brcm63xx/smp/profiles/101-Broadcom-wl.mk19
-rw-r--r--target/linux/brcm63xx/smp/profiles/102-Atheros.mk17
-rw-r--r--target/linux/brcm63xx/smp/profiles/103-Ralink.mk13
-rw-r--r--target/linux/brcm63xx/smp/profiles/104-No-WiFi.mk17
-rw-r--r--target/linux/brcm63xx/smp/profiles/105-Broadcom-brcmsmac.mk17
6 files changed, 100 insertions, 0 deletions
diff --git a/target/linux/brcm63xx/smp/profiles/100-Broadcom.mk b/target/linux/brcm63xx/smp/profiles/100-Broadcom.mk
new file mode 100644
index 0000000000..bc68f14937
--- /dev/null
+++ b/target/linux/brcm63xx/smp/profiles/100-Broadcom.mk
@@ -0,0 +1,17 @@
+#
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/Broadcom
+ NAME:=Broadcom WiFi (default)
+ PACKAGES:=kmod-b43 wpad-mini
+endef
+
+define Profile/Broadcom/Description
+ Package set compatible with hardware using Broadcom WiFi cards
+endef
+$(eval $(call Profile,Broadcom))
+
diff --git a/target/linux/brcm63xx/smp/profiles/101-Broadcom-wl.mk b/target/linux/brcm63xx/smp/profiles/101-Broadcom-wl.mk
new file mode 100644
index 0000000000..4f2d605eb7
--- /dev/null
+++ b/target/linux/brcm63xx/smp/profiles/101-Broadcom-wl.mk
@@ -0,0 +1,19 @@
+#
+# Copyright (C) 2010 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/Broadcom-wl
+ NAME:=Broadcom BCM43xx WiFi (wl, proprietary)
+ PACKAGES:= kmod-brcm-wl wlc nas
+endef
+
+define Profile/Broadcom-wl/Description
+ Package set compatible with hardware using Broadcom BCM43xx cards
+ using the proprietary broadcom wireless "wl" driver.
+endef
+
+$(eval $(call Profile,Broadcom-wl))
+
diff --git a/target/linux/brcm63xx/smp/profiles/102-Atheros.mk b/target/linux/brcm63xx/smp/profiles/102-Atheros.mk
new file mode 100644
index 0000000000..b214185c5d
--- /dev/null
+++ b/target/linux/brcm63xx/smp/profiles/102-Atheros.mk
@@ -0,0 +1,17 @@
+#
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/Atheros
+ NAME:=Atheros WiFi (default)
+ PACKAGES:=kmod-ath5k kmod-ath9k wpad-mini
+endef
+
+define Profile/Atheros/Description
+ Package set compatible with hardware using Atheros WiFi cards
+endef
+$(eval $(call Profile,Atheros))
+
diff --git a/target/linux/brcm63xx/smp/profiles/103-Ralink.mk b/target/linux/brcm63xx/smp/profiles/103-Ralink.mk
new file mode 100644
index 0000000000..412c5a45ad
--- /dev/null
+++ b/target/linux/brcm63xx/smp/profiles/103-Ralink.mk
@@ -0,0 +1,13 @@
+#
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/Ralink
+ NAME:=Ralink WiFi
+ PACKAGES:=kmod-rt61-pci wpad-mini
+endef
+$(eval $(call Profile,Ralink))
+
diff --git a/target/linux/brcm63xx/smp/profiles/104-No-WiFi.mk b/target/linux/brcm63xx/smp/profiles/104-No-WiFi.mk
new file mode 100644
index 0000000000..0f5ec37cf6
--- /dev/null
+++ b/target/linux/brcm63xx/smp/profiles/104-No-WiFi.mk
@@ -0,0 +1,17 @@
+#
+# Copyright (C) 2009 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/NoWiFi
+ NAME:=No WiFi
+ PACKAGES:=
+endef
+
+define Profile/NoWiFi/description
+ Package set compatible with BCM63xx routers without Wi-Fi.
+endef
+
+$(eval $(call Profile,NoWiFi))
diff --git a/target/linux/brcm63xx/smp/profiles/105-Broadcom-brcmsmac.mk b/target/linux/brcm63xx/smp/profiles/105-Broadcom-brcmsmac.mk
new file mode 100644
index 0000000000..bb558d1390
--- /dev/null
+++ b/target/linux/brcm63xx/smp/profiles/105-Broadcom-brcmsmac.mk
@@ -0,0 +1,17 @@
+#
+# Copyright (C) 2012 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/Broadcom-brcmsmac
+ NAME:=Broadcom WiFi (brcmsmac)
+ PACKAGES:=kmod-brcmsmac wpad-mini
+endef
+
+define Profile/Broadcom-brcmsmac/Description
+ Package set compatible with hardware using Broadcom WiFi cards
+endef
+$(eval $(call Profile,Broadcom-brcmsmac))
+