aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/brcm63xx/profiles
diff options
context:
space:
mode:
authorAndrius Štikonas <andrius@stikonas.eu>2018-07-14 21:53:47 +0000
committerJohn Crispin <john@phrozen.org>2018-07-16 15:12:08 +0200
commitd591260407015d2c451ad8c9e114fe04cf3639bc (patch)
treea1e4883e39dcfaf39bcf9f24fd8fd553a761df5c /target/linux/brcm63xx/profiles
parentc3f9a1ac0e7ae536552e2745582dc47098cefc07 (diff)
downloadupstream-d591260407015d2c451ad8c9e114fe04cf3639bc.tar.gz
upstream-d591260407015d2c451ad8c9e114fe04cf3639bc.tar.bz2
upstream-d591260407015d2c451ad8c9e114fe04cf3639bc.zip
brcm63xx: initial support for Sky SR102 router
The sender domain has a DMARC Reject/Quarantine policy which disallows sending mailing list messages using the original "From" header. To mitigate this problem, the original message has been wrapped automatically by the mailing list software. SOC: BCM63168 (BMIPS4350 V8.0 @400MHz) Flash size: 16 MiB RAM size: 128 MiB Heavily based on patch for OpenWRT Chaos Chalmer. Original patch and more info can be found at: https://openwrt.org/toh/sky/sr102 Known issues: - Wireless and ADSL modem are not working. Signed-off-by: Andrius Štikonas <andrius@stikonas.eu>
Diffstat (limited to 'target/linux/brcm63xx/profiles')
-rw-r--r--target/linux/brcm63xx/profiles/sky.mk16
1 files changed, 16 insertions, 0 deletions
diff --git a/target/linux/brcm63xx/profiles/sky.mk b/target/linux/brcm63xx/profiles/sky.mk
new file mode 100644
index 0000000000..f209794800
--- /dev/null
+++ b/target/linux/brcm63xx/profiles/sky.mk
@@ -0,0 +1,16 @@
+#
+# Copyright (C) 2015 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/SR102
+ NAME:=SKY SR102
+ PACKAGES:=kmod-b43 wpad-mini \
+ kmod-usb2 kmod-usb-ohci
+endef
+define Profile/SR102/Description
+ Package set optimized for SKY SR102.
+endef
+$(eval $(call Profile,SR102))