aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/brcm63xx/image
diff options
context:
space:
mode:
authorDaniel Dickinson <crazycshore@gmail.com>2010-11-28 22:04:40 +0000
committerDaniel Dickinson <crazycshore@gmail.com>2010-11-28 22:04:40 +0000
commit3a49f669f2fe726f6350a5e0a71af70824a13f54 (patch)
treed317658fc7a021357b3ca2a6a988cd8d0df416d7 /target/linux/brcm63xx/image
parentc51d772e62a57c3659fca01b95f930ba6288b9e7 (diff)
downloadupstream-3a49f669f2fe726f6350a5e0a71af70824a13f54.tar.gz
upstream-3a49f669f2fe726f6350a5e0a71af70824a13f54.tar.bz2
upstream-3a49f669f2fe726f6350a5e0a71af70824a13f54.zip
bcm63xx: Add board id override fixup.
Add a fixup for the kernel to check the bcm tag of the image for a boardid in the information1 field, and use that instead of the supplied one by cfe. This is triggered by a + at the start of the information1 field. Also modify the image generation to generate apropriately tagged images. Signed-off-by: Jonas Gorski <jonas.gorski+openwrt@gmail.com> SVN-Revision: 24189
Diffstat (limited to 'target/linux/brcm63xx/image')
-rw-r--r--target/linux/brcm63xx/image/Makefile16
1 files changed, 13 insertions, 3 deletions
diff --git a/target/linux/brcm63xx/image/Makefile b/target/linux/brcm63xx/image/Makefile
index 588745cd2c..589e47c561 100644
--- a/target/linux/brcm63xx/image/Makefile
+++ b/target/linux/brcm63xx/image/Makefile
@@ -37,7 +37,17 @@ define Image/Build/CFE
--output $(BIN_DIR)/openwrt-$(4)-$(1)-cfe.bin \
--boardid $(2) --chipid $(3) --entry $(KERNEL_ENTRY) \
--load-addr $(LOADADDR) --rsa-signature "$(5)" \
- --info1 "$(call Image/LimitName16,$(4))" --info2 $(1) \
+ --info1 "-$(call Image/LimitName16,$(4))" --info2 $(1) \
+ $(6) $(7) $(8) $(9)
+endef
+
+define Image/Build/CFEFIXUP
+ # Generate the tagged image
+ $(STAGING_DIR_HOST)/bin/imagetag -i $(KDIR)/vmlinux.lzma.cfe -f $(KDIR)/root.$(1) \
+ --output $(BIN_DIR)/openwrt-$(4)-$(1)-cfe.bin \
+ --boardid $(2) --chipid $(3) --entry $(KERNEL_ENTRY) \
+ --load-addr $(LOADADDR) --rsa-signature "$(5)" \
+ --info1 "+$(call Image/LimitName16,$(4))" --info2 $(1) \
$(6) $(7) $(8) $(9)
endef
@@ -48,7 +58,7 @@ define Image/Build/CFEAGPF
--boardid $(2) --chipid $(3) --entry $(LOADADDR) \
--load-addr $(LOADADDR) --tag-version 8 \
--signature2 IMAGE --block-size 0x20000 \
- --image-offset $(4) --info1 "$(call Image/LimitName16,$(5))" --info2 $(1)
+ --image-offset $(4) --info1 "-$(call Image/LimitName16,$(5))" --info2 $(1)
endef
define Image/Build/RG100A
@@ -57,7 +67,7 @@ define Image/Build/RG100A
--output $(BIN_DIR)/openwrt-$(5)-$(1)-cfe.bin \
--boardid $(2) --chipid $(3) --entry $(LOADADDR) \
--load-addr $(LOADADDR) --block-size 0x20000 \
- --image-offset $(4) --info1 "$(call Image/LimitName16,$(5))" --info2 $(1)
+ --image-offset $(4) --info1 "-$(call Image/LimitName16,$(5))" --info2 $(1)
endef
define Image/Build/RedBoot