aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/brcm63xx/image
diff options
context:
space:
mode:
authorDaniel Gonzalez Cabanelas <dgcbueu@gmail.com>2016-12-03 15:51:05 +0100
committerJonas Gorski <jonas.gorski@gmail.com>2017-02-09 22:02:45 +0100
commit41ad9ed13a7792775ad3cca88e9d4eac6e594c63 (patch)
tree606941a34216d2c0c66366cb57ce69f408513691 /target/linux/brcm63xx/image
parentbe4842f5de346e463ae44cd0e161ce80311f0374 (diff)
downloadupstream-41ad9ed13a7792775ad3cca88e9d4eac6e594c63.tar.gz
upstream-41ad9ed13a7792775ad3cca88e9d4eac6e594c63.tar.bz2
upstream-41ad9ed13a7792775ad3cca88e9d4eac6e594c63.zip
brcm63xx: Add Observa VH4032N support
Add support for the Observa Telecom VH4032N router. This is another BCM6368 router, 128 MB RAM, 32MB flash and 3 USB host ports. The wifi chip is an onboard Broadcom BCM43222. Signed-off-by: Daniel Gonzalez Cabanelas <dgcbueu@gmail.com> [jonas.gorski: use gpio-hog instead of abusing ephy-reset] Signed-off-by: Jonas Gorski <jonas.gorski@gmail.com>
Diffstat (limited to 'target/linux/brcm63xx/image')
-rw-r--r--target/linux/brcm63xx/image/bcm63xx.mk15
1 files changed, 15 insertions, 0 deletions
diff --git a/target/linux/brcm63xx/image/bcm63xx.mk b/target/linux/brcm63xx/image/bcm63xx.mk
index f38147eb36..0749c292e3 100644
--- a/target/linux/brcm63xx/image/bcm63xx.mk
+++ b/target/linux/brcm63xx/image/bcm63xx.mk
@@ -818,6 +818,21 @@ define Device/R5010UNv2
endef
TARGET_DEVICES += R5010UNv2
+### Observa ###
+define Device/VH4032N
+ $(Device/bcm63xx)
+ IMAGES += sysupgrade.bin
+ DEVICE_TITLE := Observa VH4032N
+ DEVICE_DTS := vh4032n
+ CFE_BOARD_ID := 96368VVW
+ CFE_CHIP_ID := 6368
+ BLOCK_SIZE := 0x20000
+ FLASH_MB := 32
+ DEVICE_PACKAGES := \
+ $(B43_PACKAGES) $(USB2_PACKAGES)
+endef
+TARGET_DEVICES += VH4032N
+
### Pirelli ###
define Device/A226G
$(Device/bcm63xx)