aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/brcm63xx/image/bcm63xx.mk
diff options
context:
space:
mode:
authorAnthony Sepa <anthonysepa@yahoo.ca>2017-02-19 14:27:36 -0400
committerJonas Gorski <jonas.gorski@gmail.com>2017-06-30 12:12:17 +0200
commitf9b67b89d31dbffd20aedcb33cf10dfe1a206aab (patch)
tree1fa1055780a2585f08efe0a07fd1e581d0fd1936 /target/linux/brcm63xx/image/bcm63xx.mk
parent1dc7a0cfd5cdf90a8ce8381ef07bac11ad46afef (diff)
downloadupstream-f9b67b89d31dbffd20aedcb33cf10dfe1a206aab.tar.gz
upstream-f9b67b89d31dbffd20aedcb33cf10dfe1a206aab.tar.bz2
upstream-f9b67b89d31dbffd20aedcb33cf10dfe1a206aab.zip
brcm63xx: add support for the Actiontec R1000H gateway
SOC: Broadcom BCM6368 (2 * Broadcom BMIPS4350 V3.1 / 400 MHz) Flash size: 32MB (split 16/16 dual boot) RAM size: 64MB Wireless: BCM432x 802.11a/b/g/n(pci) Ethernet: Broadcom BCM53115 USB: 1 x USB 2.0 Known issues: - Unable to detect 53115 switch attached to MDIO. Not supported - No support for the cable port More info on the device and the research can be found at: http://www.actiontec.com/212.html Same FCC ID as: https://wikidevi.com/wiki/Actiontec_V1000H_(Telus) Signed-off-by: Anthony Sepa <anthonysepa@yahoo.ca> [jonas.gorski: fix commit subject/message] Signed-off-by: Jonas Gorski <jonas.gorski@gmail.com>
Diffstat (limited to 'target/linux/brcm63xx/image/bcm63xx.mk')
-rw-r--r--target/linux/brcm63xx/image/bcm63xx.mk16
1 files changed, 16 insertions, 0 deletions
diff --git a/target/linux/brcm63xx/image/bcm63xx.mk b/target/linux/brcm63xx/image/bcm63xx.mk
index 04cbf124a7..dd1ad86501 100644
--- a/target/linux/brcm63xx/image/bcm63xx.mk
+++ b/target/linux/brcm63xx/image/bcm63xx.mk
@@ -1,3 +1,4 @@
+
#
# BCM33XX/BCM63XX Profiles
#
@@ -174,6 +175,21 @@ define Device/96368MVWG-generic
endef
TARGET_DEVICES += 96368MVWG-generic
+### Actiontec ###
+define Device/R1000H
+ $(Device/bcm63xx)
+ FILESYSTEMS := squashfs
+ DEVICE_TITLE := Actiontec R1000H
+ DEVICE_DTS := r1000h
+ CFE_BOARD_ID := 96368MVWG
+ CFE_CHIP_ID := 6368
+ FLASH_MB := 32
+ IMAGE_OFFSET := 0x20000
+ DEVICE_PACKAGES := \
+ $(USB2_PACKAGES) $(BRCMWL_PACKAGES)
+endef
+TARGET_DEVICES += R1000H
+
### ADB ###
define Device/A4001N
$(Device/bcm63xx)