aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/brcm63xx/image/Makefile
diff options
context:
space:
mode:
authorÁlvaro Fernández Rojas <noltari@gmail.com>2016-06-21 13:53:45 +0200
committerÁlvaro Fernández Rojas <noltari@gmail.com>2016-06-21 16:42:44 +0200
commit13253fbcbd7e5cac2d78e3422ea32fa4b52ce917 (patch)
tree7eba1bede3dd563b608b687957d4d58b3d759311 /target/linux/brcm63xx/image/Makefile
parent7df43d88eca9a518c2e066a380aeddd8b026d534 (diff)
downloadupstream-13253fbcbd7e5cac2d78e3422ea32fa4b52ce917.tar.gz
upstream-13253fbcbd7e5cac2d78e3422ea32fa4b52ce917.tar.bz2
upstream-13253fbcbd7e5cac2d78e3422ea32fa4b52ce917.zip
brcm63xx: add sysupgrade images
Some devices require padded images in order to prevent CFE from flashing them to the wrong offset. For small flashes (4/8) this is no big deal, but for larger flashes (16/32) this implies 8 and 16 MB images, which is way too large and some devices aren't capable of flashing them through sysupgrade. Signed-off-by: Álvaro Fernández Rojas <noltari@gmail.com>
Diffstat (limited to 'target/linux/brcm63xx/image/Makefile')
-rw-r--r--target/linux/brcm63xx/image/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/target/linux/brcm63xx/image/Makefile b/target/linux/brcm63xx/image/Makefile
index 5471ddd420..d2a381431d 100644
--- a/target/linux/brcm63xx/image/Makefile
+++ b/target/linux/brcm63xx/image/Makefile
@@ -129,7 +129,7 @@ define Build/cfe-spw303v-bin
--output $@ --boardid $(CFE_BOARD_ID) --chipid $(CFE_CHIP_ID) \
--entry $(LOADER_ENTRY) --load-addr $(LOADER_ENTRY) \
$(call rootfspad/$(call Image/FileSystemStrip,$(word 2,$^))) \
- $(CFE_EXTRAS)
+ $(CFE_EXTRAS) $(1)
endef
define Build/spw303v-bin