aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/brcm63xx/image/Makefile
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2008-04-01 21:10:47 +0000
committerFlorian Fainelli <florian@openwrt.org>2008-04-01 21:10:47 +0000
commit25e156e1cf43da5cc23027c5620a46008bca6de3 (patch)
tree510d86e3906eef499f055c7814f9db4b4192fa78 /target/linux/brcm63xx/image/Makefile
parent3dc36775ced6be8dac9e25f59120d7ebc6ab002b (diff)
downloadupstream-25e156e1cf43da5cc23027c5620a46008bca6de3.tar.gz
upstream-25e156e1cf43da5cc23027c5620a46008bca6de3.tar.bz2
upstream-25e156e1cf43da5cc23027c5620a46008bca6de3.zip
brcm63xx image generation cleanups (#3169)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@10703 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/brcm63xx/image/Makefile')
-rw-r--r--target/linux/brcm63xx/image/Makefile5
1 files changed, 5 insertions, 0 deletions
diff --git a/target/linux/brcm63xx/image/Makefile b/target/linux/brcm63xx/image/Makefile
index 04231b4e85..fab73efd20 100644
--- a/target/linux/brcm63xx/image/Makefile
+++ b/target/linux/brcm63xx/image/Makefile
@@ -39,10 +39,15 @@ define Image/Prepare
TARGET="$(KDIR)" \
clean install
echo -ne "\\x00" >> $(KDIR)/loader.gz
+ rm -f $(KDIR)/fs_mark
+ touch $(KDIR)/fs_mark
+ $(call prepare_generic_squashfs,$(KDIR)/fs_mark)
endef
define Image/Build
+ifneq($(1),ext2)
$(STAGING_DIR_HOST)/bin/trx -o $(BIN_DIR)/openwrt-$(BOARD)-$(1).trx -f $(KDIR)/loader.gz -f $(KDIR)/vmlinux.lzma $(call trxalign/$(1)) -f $(KDIR)/root.$(1)
+endif
endef
$(eval $(call BuildImage))