aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/brcm63xx/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-09-08 19:55:42 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-09-08 19:55:42 +0000
commita9d683ca912b2c4837b2e65909c09ca01babe3df (patch)
tree6cbca6e13dd0bb18c9d9f1d4baa9a0ea7801b959 /target/linux/brcm63xx/Makefile
parent4a2e4920b1d909ca254853b0dce46af3123e8f74 (diff)
downloadupstream-a9d683ca912b2c4837b2e65909c09ca01babe3df.tar.gz
upstream-a9d683ca912b2c4837b2e65909c09ca01babe3df.tar.bz2
upstream-a9d683ca912b2c4837b2e65909c09ca01babe3df.zip
major target cleanup. it is now possible to have subtargets that can override many target settings, including arch - merge adm5120, adm5120eb. target profiles still need to be adapted for subtargets
SVN-Revision: 8694
Diffstat (limited to 'target/linux/brcm63xx/Makefile')
-rw-r--r--target/linux/brcm63xx/Makefile7
1 files changed, 3 insertions, 4 deletions
diff --git a/target/linux/brcm63xx/Makefile b/target/linux/brcm63xx/Makefile
index 32bfd06fea..93670c6eed 100644
--- a/target/linux/brcm63xx/Makefile
+++ b/target/linux/brcm63xx/Makefile
@@ -10,17 +10,16 @@ ARCH:=mips
BOARD:=brcm63xx
BOARDNAME:=Broadcom BCM963xx
FEATURES:=squashfs jffs2 broken usb atm
-
LINUX_VERSION:=2.6.22.4
+include $(INCLUDE_DIR)/target.mk
+
define Target/Description
Build firmware images for Broadcom based xDSL/routers
(e.g. Inventel Livebox, Siemens SE515)
endef
-include $(INCLUDE_DIR)/kernel-build.mk
-
# include the profiles
-include profiles/*.mk
-$(eval $(call BuildKernel))
+$(eval $(call BuildTarget))