aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/brcm63xx-2.6/image/Makefile
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2007-04-08 17:20:01 +0000
committerFlorian Fainelli <florian@openwrt.org>2007-04-08 17:20:01 +0000
commitebfd23d3b4233965b9094f640f633228f0b44984 (patch)
treef956bac450accbf5a884308d5e98b2f2e9401f1e /target/linux/brcm63xx-2.6/image/Makefile
parent01e84cef1a988834b444b7bebba15f5268873d35 (diff)
downloadupstream-ebfd23d3b4233965b9094f640f633228f0b44984.tar.gz
upstream-ebfd23d3b4233965b9094f640f633228f0b44984.tar.bz2
upstream-ebfd23d3b4233965b9094f640f633228f0b44984.zip
Major cleanup : - no more Broadcom kerSys* code - working runtime boot loader detection - updated flash map driver
SVN-Revision: 6896
Diffstat (limited to 'target/linux/brcm63xx-2.6/image/Makefile')
-rw-r--r--target/linux/brcm63xx-2.6/image/Makefile21
1 files changed, 18 insertions, 3 deletions
diff --git a/target/linux/brcm63xx-2.6/image/Makefile b/target/linux/brcm63xx-2.6/image/Makefile
index 51c658a093..d930af8501 100644
--- a/target/linux/brcm63xx-2.6/image/Makefile
+++ b/target/linux/brcm63xx-2.6/image/Makefile
@@ -17,17 +17,32 @@ LOADER_MAKEOPTS= \
KERNEL_ENTRY=$(KERNEL_ENTRY) \
RAMSIZE=$(RAMSIZE)
+define trxalign/jffs2-128k
+-a 0x20000
+endef
+define trxalign/jffs2-64k
+-a 0x10000
+endef
+define trxalign/squashfs
+-a 1024
+endef
+
define Build/Clean
- $(MAKE) -C $(GENERIC_PLATFORM_DIR)/image/lzma-loader $(LOADER_MAKEOPTS) clean
+ $(MAKE) -C lzma-loader clean
endef
define Image/Prepare
cat $(KDIR)/vmlinux | $(STAGING_DIR)/bin/lzma e -si -so -eos -lc1 -lp2 -pb2 > $(KDIR)/vmlinux.lzma
- $(MAKE) -C $(GENERIC_PLATFORM_DIR)/image/lzma-loader $(LOADER_MAKEOPTS) clean compile
+ rm -f $(KDIR)/loader.gz
+ $(MAKE) -C lzma-loader \
+ BUILD_DIR="$(KDIR)" \
+ TARGET="$(KDIR)" \
+ clean install
+ echo -ne "\\x00" >> $(KDIR)/loader.gz
endef
define Image/Build
- cp $(KDIR)/vmlinux $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(1).img
+ $(STAGING_DIR)/bin/trx -o $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(1).trx -f $(KDIR)/loader.gz -f $(KDIR)/vmlinux.lzma $(call trxalign/$(1)) -f $(KDIR)/root.$(1)
endef
$(eval $(call BuildImage))