aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/brcm47xx
diff options
context:
space:
mode:
authorHauke Mehrtens <hauke@hauke-m.de>2014-02-04 23:30:38 +0000
committerHauke Mehrtens <hauke@hauke-m.de>2014-02-04 23:30:38 +0000
commit14113eb88f776f2d299a58df31d9fcf6c03c9f6f (patch)
treed448d7b4eca34e0829fece5ce5f20f714c68e648 /target/linux/brcm47xx
parentdb73f1433b7f64f6005c2b91e89fe611ed9435d2 (diff)
downloadupstream-14113eb88f776f2d299a58df31d9fcf6c03c9f6f.tar.gz
upstream-14113eb88f776f2d299a58df31d9fcf6c03c9f6f.tar.bz2
upstream-14113eb88f776f2d299a58df31d9fcf6c03c9f6f.zip
brcm47xx: use upstream patch removing WGT634U code
It does the same, it just reorders things Signed-off-by: Rafał Miłecki <zajec5@gmail.com> SVN-Revision: 39468
Diffstat (limited to 'target/linux/brcm47xx')
-rw-r--r--target/linux/brcm47xx/patches-3.10/127-MIPS-BCM47XX-Drop-WGT634U-hacks.patch (renamed from target/linux/brcm47xx/patches-3.10/812-disable_wgt634u_crap.patch)27
-rw-r--r--target/linux/brcm47xx/patches-3.10/400-arch-bcm47xx.patch5
2 files changed, 27 insertions, 5 deletions
diff --git a/target/linux/brcm47xx/patches-3.10/812-disable_wgt634u_crap.patch b/target/linux/brcm47xx/patches-3.10/127-MIPS-BCM47XX-Drop-WGT634U-hacks.patch
index e29fa62774..5a091e6894 100644
--- a/target/linux/brcm47xx/patches-3.10/812-disable_wgt634u_crap.patch
+++ b/target/linux/brcm47xx/patches-3.10/127-MIPS-BCM47XX-Drop-WGT634U-hacks.patch
@@ -1,9 +1,32 @@
+From 68e30f30875d4e4608cebec27ca8bd07be0d0f64 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Rafa=C5=82=20Mi=C5=82ecki?= <zajec5@gmail.com>
+Date: Thu, 2 Jan 2014 13:53:15 +0100
+Subject: [PATCH] MIPS: BCM47XX: Drop WGT634U hacks
+MIME-Version: 1.0
+Content-Type: text/plain; charset=UTF-8
+Content-Transfer-Encoding: 8bit
+
+This old wgt634u.c was trying to implement a bit ugly support for
+Netgear WGT634U. It provided info about LED, flash mapping & layout and
+was trying to handle reset button.
+
+This is not needed anymore as we have replacement for all this stuff.
+
+Signed-off-by: Rafał Miłecki <zajec5@gmail.com>
+Signed-off-by: John Crispin <blogic@openwrt.org>
+Patchwork: http://patchwork.linux-mips.org/patch/6302/
+---
+ arch/mips/bcm47xx/Makefile | 1 -
+ arch/mips/bcm47xx/wgt634u.c | 174 --------------------------------------------
+ 2 files changed, 175 deletions(-)
+ delete mode 100644 arch/mips/bcm47xx/wgt634u.c
+
--- a/arch/mips/bcm47xx/Makefile
+++ b/arch/mips/bcm47xx/Makefile
-@@ -6,4 +6,3 @@
+@@ -5,4 +5,3 @@
+
obj-y += irq.o nvram.o prom.o serial.o setup.o time.o sprom.o
obj-y += board.o buttons.o leds.o
- obj-y += gpio.o
-obj-$(CONFIG_BCM47XX_SSB) += wgt634u.o
--- a/arch/mips/bcm47xx/wgt634u.c
+++ /dev/null
diff --git a/target/linux/brcm47xx/patches-3.10/400-arch-bcm47xx.patch b/target/linux/brcm47xx/patches-3.10/400-arch-bcm47xx.patch
index 7ea3f87c64..43aeaf152e 100644
--- a/target/linux/brcm47xx/patches-3.10/400-arch-bcm47xx.patch
+++ b/target/linux/brcm47xx/patches-3.10/400-arch-bcm47xx.patch
@@ -33,12 +33,11 @@
+EXPORT_SYMBOL(nvram_get);
--- a/arch/mips/bcm47xx/Makefile
+++ b/arch/mips/bcm47xx/Makefile
-@@ -5,4 +5,5 @@
+@@ -5,3 +5,4 @@
obj-y += irq.o nvram.o prom.o serial.o setup.o time.o sprom.o
- obj-y += board.o buttons.o leds.o
+ obj-y += board.o buttons.o leds.o workarounds.o
+obj-y += gpio.o
- obj-$(CONFIG_BCM47XX_SSB) += wgt634u.o
--- /dev/null
+++ b/arch/mips/bcm47xx/gpio.c
@@ -0,0 +1,119 @@