aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/brcm47xx
diff options
context:
space:
mode:
authorJonas Gorski <jogo@openwrt.org>2012-01-31 09:43:53 +0000
committerJonas Gorski <jogo@openwrt.org>2012-01-31 09:43:53 +0000
commite67f4477bb4a423a0d45418a5c0d228d425ecbce (patch)
tree7d8a4c3250532ecdb662e2824fc43f4287176f3e /target/linux/brcm47xx
parent882eddbf92fb86d75d701d3bcbc32ac4a7dbbb16 (diff)
downloadupstream-e67f4477bb4a423a0d45418a5c0d228d425ecbce.tar.gz
upstream-e67f4477bb4a423a0d45418a5c0d228d425ecbce.tar.bz2
upstream-e67f4477bb4a423a0d45418a5c0d228d425ecbce.zip
kernel: update linux 3.0 to 3.0.18
SVN-Revision: 29965
Diffstat (limited to 'target/linux/brcm47xx')
-rw-r--r--target/linux/brcm47xx/Makefile2
-rw-r--r--target/linux/brcm47xx/patches-3.0/0045-ssb-fix-cardbus-in-hostmode.patch4
2 files changed, 3 insertions, 3 deletions
diff --git a/target/linux/brcm47xx/Makefile b/target/linux/brcm47xx/Makefile
index 8f3362a870..0212ee6806 100644
--- a/target/linux/brcm47xx/Makefile
+++ b/target/linux/brcm47xx/Makefile
@@ -11,7 +11,7 @@ BOARD:=brcm47xx
BOARDNAME:=Broadcom BCM947xx/953xx
FEATURES:=squashfs usb pcmcia
-LINUX_VERSION:=3.0.17
+LINUX_VERSION:=3.0.18
include $(INCLUDE_DIR)/target.mk
DEFAULT_PACKAGES += wpad-mini kmod-switch kmod-diag nvram
diff --git a/target/linux/brcm47xx/patches-3.0/0045-ssb-fix-cardbus-in-hostmode.patch b/target/linux/brcm47xx/patches-3.0/0045-ssb-fix-cardbus-in-hostmode.patch
index 4837fe740f..0a329c00a3 100644
--- a/target/linux/brcm47xx/patches-3.0/0045-ssb-fix-cardbus-in-hostmode.patch
+++ b/target/linux/brcm47xx/patches-3.0/0045-ssb-fix-cardbus-in-hostmode.patch
@@ -11,7 +11,7 @@ Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
--- a/drivers/ssb/driver_pcicore.c
+++ b/drivers/ssb/driver_pcicore.c
-@@ -75,7 +75,7 @@ static u32 get_cfgspace_addr(struct ssb_
+@@ -74,7 +74,7 @@ static u32 get_cfgspace_addr(struct ssb_
u32 tmp;
/* We do only have one cardbus device behind the bridge. */
@@ -19,4 +19,4 @@ Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
+ if (pc->cardbusmode && (dev > 1))
goto out;
- /* Type 0 transaction */
+ if (bus == 0) {