aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/brcm47xx
diff options
context:
space:
mode:
authorJonas Gorski <jogo@openwrt.org>2012-01-13 14:10:44 +0000
committerJonas Gorski <jogo@openwrt.org>2012-01-13 14:10:44 +0000
commite49d3e1d5bdbaabe80dd0e3d0b4da93b2914461e (patch)
tree1faff269ee56e774bd2df1d8c499303b639a1707 /target/linux/brcm47xx
parent0cb05017c63b4b627948ed3d75a054a327a56ebf (diff)
downloadupstream-e49d3e1d5bdbaabe80dd0e3d0b4da93b2914461e.tar.gz
upstream-e49d3e1d5bdbaabe80dd0e3d0b4da93b2914461e.tar.bz2
upstream-e49d3e1d5bdbaabe80dd0e3d0b4da93b2914461e.zip
kernel: update linux 3.0 to 3.0.17
SVN-Revision: 29725
Diffstat (limited to 'target/linux/brcm47xx')
-rw-r--r--target/linux/brcm47xx/Makefile2
-rw-r--r--target/linux/brcm47xx/patches-3.0/0030-USB-OHCI-Add-a-generic-platform-device-driver.patch8
-rw-r--r--target/linux/brcm47xx/patches-3.0/0034-USB-OHCI-remove-old-SSB-OHCI-driver.patch10
3 files changed, 10 insertions, 10 deletions
diff --git a/target/linux/brcm47xx/Makefile b/target/linux/brcm47xx/Makefile
index eb4d9aff9a..8f3362a870 100644
--- a/target/linux/brcm47xx/Makefile
+++ b/target/linux/brcm47xx/Makefile
@@ -11,7 +11,7 @@ BOARD:=brcm47xx
BOARDNAME:=Broadcom BCM947xx/953xx
FEATURES:=squashfs usb pcmcia
-LINUX_VERSION:=3.0.12
+LINUX_VERSION:=3.0.17
include $(INCLUDE_DIR)/target.mk
DEFAULT_PACKAGES += wpad-mini kmod-switch kmod-diag nvram
diff --git a/target/linux/brcm47xx/patches-3.0/0030-USB-OHCI-Add-a-generic-platform-device-driver.patch b/target/linux/brcm47xx/patches-3.0/0030-USB-OHCI-Add-a-generic-platform-device-driver.patch
index 51b112a2d3..6f22aa0508 100644
--- a/target/linux/brcm47xx/patches-3.0/0030-USB-OHCI-Add-a-generic-platform-device-driver.patch
+++ b/target/linux/brcm47xx/patches-3.0/0030-USB-OHCI-Add-a-generic-platform-device-driver.patch
@@ -37,7 +37,7 @@ Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
depends on USB_OHCI_HCD
--- a/drivers/usb/host/ohci-hcd.c
+++ b/drivers/usb/host/ohci-hcd.c
-@@ -1114,6 +1114,11 @@ MODULE_LICENSE ("GPL");
+@@ -1111,6 +1111,11 @@ MODULE_LICENSE ("GPL");
#define PLATFORM_DRIVER ohci_hcd_ath79_driver
#endif
@@ -49,7 +49,7 @@ Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
#if !defined(PCI_DRIVER) && \
!defined(PLATFORM_DRIVER) && \
!defined(OMAP1_PLATFORM_DRIVER) && \
-@@ -1123,7 +1128,8 @@ MODULE_LICENSE ("GPL");
+@@ -1120,7 +1125,8 @@ MODULE_LICENSE ("GPL");
!defined(PS3_SYSTEM_BUS_DRIVER) && \
!defined(SM501_OHCI_DRIVER) && \
!defined(TMIO_OHCI_DRIVER) && \
@@ -59,7 +59,7 @@ Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
#error "missing bus glue for ohci-hcd"
#endif
-@@ -1207,9 +1213,19 @@ static int __init ohci_hcd_mod_init(void
+@@ -1204,9 +1210,19 @@ static int __init ohci_hcd_mod_init(void
goto error_tmio;
#endif
@@ -79,7 +79,7 @@ Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
#ifdef TMIO_OHCI_DRIVER
platform_driver_unregister(&TMIO_OHCI_DRIVER);
error_tmio:
-@@ -1263,6 +1279,9 @@ module_init(ohci_hcd_mod_init);
+@@ -1260,6 +1276,9 @@ module_init(ohci_hcd_mod_init);
static void __exit ohci_hcd_mod_exit(void)
{
diff --git a/target/linux/brcm47xx/patches-3.0/0034-USB-OHCI-remove-old-SSB-OHCI-driver.patch b/target/linux/brcm47xx/patches-3.0/0034-USB-OHCI-remove-old-SSB-OHCI-driver.patch
index 18c3e9f8e5..140088c6d5 100644
--- a/target/linux/brcm47xx/patches-3.0/0034-USB-OHCI-remove-old-SSB-OHCI-driver.patch
+++ b/target/linux/brcm47xx/patches-3.0/0034-USB-OHCI-remove-old-SSB-OHCI-driver.patch
@@ -38,7 +38,7 @@ Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
depends on USB_OHCI_HCD && SUPERH
--- a/drivers/usb/host/ohci-hcd.c
+++ b/drivers/usb/host/ohci-hcd.c
-@@ -1079,11 +1079,6 @@ MODULE_LICENSE ("GPL");
+@@ -1076,11 +1076,6 @@ MODULE_LICENSE ("GPL");
#define PS3_SYSTEM_BUS_DRIVER ps3_ohci_driver
#endif
@@ -50,7 +50,7 @@ Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
#ifdef CONFIG_MFD_SM501
#include "ohci-sm501.c"
#define SM501_OHCI_DRIVER ohci_hcd_sm501_driver
-@@ -1128,7 +1123,6 @@ MODULE_LICENSE ("GPL");
+@@ -1125,7 +1120,6 @@ MODULE_LICENSE ("GPL");
!defined(PS3_SYSTEM_BUS_DRIVER) && \
!defined(SM501_OHCI_DRIVER) && \
!defined(TMIO_OHCI_DRIVER) && \
@@ -58,7 +58,7 @@ Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
!defined(PLATFORM_OHCI_DRIVER)
#error "missing bus glue for ohci-hcd"
#endif
-@@ -1195,12 +1189,6 @@ static int __init ohci_hcd_mod_init(void
+@@ -1192,12 +1186,6 @@ static int __init ohci_hcd_mod_init(void
goto error_pci;
#endif
@@ -71,7 +71,7 @@ Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
#ifdef SM501_OHCI_DRIVER
retval = platform_driver_register(&SM501_OHCI_DRIVER);
if (retval < 0)
-@@ -1234,10 +1222,6 @@ static int __init ohci_hcd_mod_init(void
+@@ -1231,10 +1219,6 @@ static int __init ohci_hcd_mod_init(void
platform_driver_unregister(&SM501_OHCI_DRIVER);
error_sm501:
#endif
@@ -82,7 +82,7 @@ Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
#ifdef PCI_DRIVER
pci_unregister_driver(&PCI_DRIVER);
error_pci:
-@@ -1288,9 +1272,6 @@ static void __exit ohci_hcd_mod_exit(voi
+@@ -1285,9 +1269,6 @@ static void __exit ohci_hcd_mod_exit(voi
#ifdef SM501_OHCI_DRIVER
platform_driver_unregister(&SM501_OHCI_DRIVER);
#endif