aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/brcm47xx
diff options
context:
space:
mode:
authorRafał Miłecki <rafal@milecki.pl>2017-01-04 12:38:48 +0100
committerRafał Miłecki <rafal@milecki.pl>2017-01-04 12:49:03 +0100
commit2406b3488fb778b76bf86ace3d9796b5ea9e606d (patch)
treeebf25660435974f1513c5dcc2a78de123c040d69 /target/linux/brcm47xx
parent5f8e3386e06bb68c4ec71af0d0ba42ae99ad89bd (diff)
downloadupstream-2406b3488fb778b76bf86ace3d9796b5ea9e606d.tar.gz
upstream-2406b3488fb778b76bf86ace3d9796b5ea9e606d.tar.bz2
upstream-2406b3488fb778b76bf86ace3d9796b5ea9e606d.zip
brcm47xx: generic: include Ethernet drivers in standard image
Signed-off-by: Rafał Miłecki <rafal@milecki.pl>
Diffstat (limited to 'target/linux/brcm47xx')
-rw-r--r--target/linux/brcm47xx/image/Makefile5
1 files changed, 5 insertions, 0 deletions
diff --git a/target/linux/brcm47xx/image/Makefile b/target/linux/brcm47xx/image/Makefile
index 0074cf3edd..1bf577e159 100644
--- a/target/linux/brcm47xx/image/Makefile
+++ b/target/linux/brcm47xx/image/Makefile
@@ -244,6 +244,11 @@ define Device/linksys-e3000-v1
endef
TARGET_DEVICES += linksys-e3000-v1
+# generic has Ethernet drivers as modules so overwrite standard image
+define Device/standard
+ DEVICE_TITLE := Image with LZMA loader and LZMA compressed kernel
+ DEVICE_PACKAGES := kmod-b44 kmod-bgmac kmod-tg3
+endef
TARGET_DEVICES += standard
endif