aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/brcm47xx
diff options
context:
space:
mode:
authorRafał Miłecki <rafal@milecki.pl>2016-10-24 21:33:21 +0200
committerJohn Crispin <john@phrozen.org>2016-10-27 13:25:51 +0200
commitbc6be3e953e778e338157f43febc7eecb1994cef (patch)
tree88f4e73a729b4a6f34fb09d3b4b96b748025296b /target/linux/brcm47xx
parentdc8605b7f7d81d663dc57af591b6e81efcb70386 (diff)
downloadupstream-bc6be3e953e778e338157f43febc7eecb1994cef.tar.gz
upstream-bc6be3e953e778e338157f43febc7eecb1994cef.tar.bz2
upstream-bc6be3e953e778e338157f43febc7eecb1994cef.zip
brcm47xx: add support for per-device rootfs
Signed-off-by: Rafał Miłecki <rafal@milecki.pl>
Diffstat (limited to 'target/linux/brcm47xx')
-rw-r--r--target/linux/brcm47xx/image/Makefile99
1 files changed, 95 insertions, 4 deletions
diff --git a/target/linux/brcm47xx/image/Makefile b/target/linux/brcm47xx/image/Makefile
index 8cc336a2e3..5d8e6ff7d5 100644
--- a/target/linux/brcm47xx/image/Makefile
+++ b/target/linux/brcm47xx/image/Makefile
@@ -142,16 +142,19 @@ define Device/Default
endef
define Device/standard
+ DEVICE_TITLE := Image with LZMA loader and LZMA compressed kernel
endef
define Device/standard-noloader-gz
- KERNEL_NAME = vmlinux.gz
- IMAGE/trx := trx-without-loader
+ DEVICE_TITLE := Image with gzipped kernel
+ KERNEL_NAME = vmlinux.gz
+ IMAGE/trx := trx-without-loader
endef
define Device/standard-noloader-nodictionarylzma
- KERNEL_NAME = vmlinux-nodictionary.lzma
- IMAGE/trx := trx-without-loader
+ DEVICE_TITLE := Image with LZMA compressed kernel matching CFE decompressor
+ KERNEL_NAME = vmlinux-nodictionary.lzma
+ IMAGE/trx := trx-without-loader
endef
define Device/asus
@@ -181,6 +184,7 @@ endef
ifeq ($(SUBTARGET),generic)
# BCM4705 with tg3
define Device/linksys-wrt300n-v1.1
+ DEVICE_TITLE := Linksys WRT300N v1.1
$(Device/linksys)
DEVICE_ID := EWC2
VERSION := 1.51.2
@@ -188,6 +192,7 @@ endef
TARGET_DEVICES += linksys-wrt300n-v1.1
define Device/linksys-wrt310n-v1
+ DEVICE_TITLE := Linksys WRT310N v1
$(Device/linksys)
DEVICE_ID := 310N
VERSION := 1.0.10
@@ -195,6 +200,7 @@ endef
TARGET_DEVICES += linksys-wrt310n-v1
define Device/linksys-wrt350n-v1
+ DEVICE_TITLE := Linksys WRT350N v1
$(Device/linksys)
DEVICE_ID := EWCG
VERSION := 1.04.1
@@ -202,6 +208,7 @@ endef
TARGET_DEVICES += linksys-wrt350n-v1
define Device/linksys-wrt610n-v1
+ DEVICE_TITLE := Linksys WRT610N v1
$(Device/linksys)
DEVICE_ID := 610N
VERSION := 1.0.1
@@ -210,6 +217,7 @@ TARGET_DEVICES += linksys-wrt610n-v1
# BCMA SoC with SSB WiFi
define Device/linksys-wrt610n-v2
+ DEVICE_TITLE := Linksys WRT610N v2
$(Device/linksys)
DEVICE_ID := 610N
VERSION := 2.0.0
@@ -217,6 +225,7 @@ endef
TARGET_DEVICES += linksys-wrt610n-v2
define Device/linksys-e3000-v1
+ DEVICE_TITLE := Linksys E3000 v1
$(Device/linksys)
DEVICE_ID := 61XN
VERSION := 1.0.3
@@ -233,60 +242,70 @@ endif
ifeq ($(SUBTARGET),legacy)
define Device/asus-wl-300g
+ DEVICE_TITLE := Asus WL-300g
$(Device/asus)
PRODUCTID := "WL300g "
endef
TARGET_DEVICES += asus-wl-300g
define Device/asus-wl-320gp
+ DEVICE_TITLE := Asus WL-320gP
$(Device/asus)
PRODUCTID := "WL320gP "
endef
TARGET_DEVICES += asus-wl-320gp
define Device/asus-wl-330ge
+ DEVICE_TITLE := Asus WL-330gE
$(Device/asus)
PRODUCTID := "WL-330gE "
endef
TARGET_DEVICES += asus-wl-330ge
define Device/asus-wl-500gp-v1
+ DEVICE_TITLE := Asus WL-500gP v1
$(Device/asus)
PRODUCTID := "WL500gp "
endef
TARGET_DEVICES += asus-wl-500gp-v1
define Device/asus-wl-500gp-v2
+ DEVICE_TITLE := Asus WL-500gP v2
$(Device/asus)
PRODUCTID := "WL500gpv2 "
endef
TARGET_DEVICES += asus-wl-500gp-v2
define Device/asus-wl-500w
+ DEVICE_TITLE := Asus WL-500W
$(Device/asus)
PRODUCTID := "WL500W "
endef
TARGET_DEVICES += asus-wl-500w
define Device/asus-wl-520gu
+ DEVICE_TITLE := Asus WL-520gU
$(Device/asus)
PRODUCTID := "WL520gu "
endef
TARGET_DEVICES += asus-wl-520gu
define Device/asus-wl-550ge
+ DEVICE_TITLE := Asus WL-550gE
$(Device/asus)
PRODUCTID := "WL550gE "
endef
TARGET_DEVICES += asus-wl-550ge
define Device/asus-wl-hdd25
+ DEVICE_TITLE := Asus WL-HDD25
$(Device/asus)
PRODUCTID := "WLHDD "
endef
TARGET_DEVICES += asus-wl-hdd25
define Device/dlink-dwl-3150
+ DEVICE_TITLE := D-Link DWL-3150
IMAGES := bin
IMAGE/bin := trx-with-loader | tailed-bin
BIN_TAIL := BCM-5352-2050-0000000-01
@@ -294,12 +313,14 @@ endef
TARGET_DEVICES += dlink-dwl-3150
define Device/edimax-ps1208-mfg
+ DEVICE_TITLE := Edimax PS-1208MFg
IMAGES := bin
IMAGE/bin := trx-with-loader | edimax-bin
endef
TARGET_DEVICES += edimax-ps1208-mfg
define Device/huawei-e970
+ DEVICE_TITLE := Huawei E970
KERNEL_NAME = vmlinux.gz
IMAGES := bin
IMAGE/bin := trx-without-loader | huawei-bin
@@ -307,6 +328,7 @@ endef
TARGET_DEVICES += huawei-e970
define Device/linksys-wrt54g3g
+ DEVICE_TITLE := Linksys WRT54G3G
$(Device/linksys)
DEVICE_ID := W54F
VERSION := 2.20.1
@@ -314,6 +336,7 @@ endef
TARGET_DEVICES += linksys-wrt54g3g
define Device/linksys-wrt54g3g-em
+ DEVICE_TITLE := Linksys WRT54G3G-EM
$(Device/linksys)
DEVICE_ID := W3GN
VERSION := 2.20.1
@@ -321,6 +344,7 @@ endef
TARGET_DEVICES += linksys-wrt54g3g-em
define Device/linksys-wrt54g3gv2-vf
+ DEVICE_TITLE := Linksys WRT54G3GV2-VF
FILESYSTEMS := $(FS_128K)
IMAGES := noheader.bin bin
IMAGE/noheader.bin := linksys-pattern-partition | trx-v2-with-loader
@@ -332,6 +356,7 @@ endef
TARGET_DEVICES += linksys-wrt54g3gv2-vf
define Device/linksys-wrt54g
+ DEVICE_TITLE := Linksys WRT54G
$(Device/linksys)
DEVICE_ID := W54G
VERSION := 4.71.1
@@ -339,6 +364,7 @@ endef
TARGET_DEVICES += linksys-wrt54g
define Device/linksys-wrt54gs
+ DEVICE_TITLE := Linksys WRT54GS
$(Device/linksys)
FILESYSTEMS := $(FS_128K)
DEVICE_ID := W54S
@@ -347,6 +373,7 @@ endef
TARGET_DEVICES += linksys-wrt54gs
define Device/linksys-wrt54gs-v4
+ DEVICE_TITLE := Linksys WRT54GS v4
$(Device/linksys)
DEVICE_ID := W54s
VERSION := 1.09.1
@@ -354,6 +381,7 @@ endef
TARGET_DEVICES += linksys-wrt54gs-v4
define Device/linksys-wrtsl54gs
+ DEVICE_TITLE := Linksys WRTSL54GS
$(Device/linksys)
FILESYSTEMS := $(FS_128K)
DEVICE_ID := W54U
@@ -362,6 +390,7 @@ endef
TARGET_DEVICES += linksys-wrtsl54gs
define Device/linksys-wrt150n
+ DEVICE_TITLE := Linksys WRT150N
$(Device/linksys)
DEVICE_ID := N150
VERSION := 1.51.3
@@ -369,6 +398,7 @@ endef
TARGET_DEVICES += linksys-wrt150n
define Device/linksys-wrt160n-v1
+ DEVICE_TITLE := Linksys WRT160N v1
$(Device/linksys)
DEVICE_ID := N150
VERSION := 1.50.1
@@ -376,6 +406,7 @@ endef
TARGET_DEVICES += linksys-wrt160n-v1
define Device/linksys-wrt300n-v1
+ DEVICE_TITLE := Linksys WRT300N v1
$(Device/linksys)
IMAGES := bin trx
DEVICE_ID := EWCB
@@ -384,24 +415,28 @@ endef
TARGET_DEVICES += linksys-wrt300n-v1
define Device/motorola-wa840g
+ DEVICE_TITLE := Motorola WA840G
$(Device/motorola)
MOTOROLA_DEVICE := 2
endef
TARGET_DEVICES += motorola-wa840g
define Device/motorola-we800g
+ DEVICE_TITLE := Motorola WE800G
$(Device/motorola)
MOTOROLA_DEVICE := 3
endef
TARGET_DEVICES += motorola-we800g
define Device/motorola-wr850g
+ DEVICE_TITLE := Motorola WR850G
$(Device/motorola)
MOTOROLA_DEVICE := 1
endef
TARGET_DEVICES += motorola-wr850g
define Device/netgear-wgr614-v8
+ DEVICE_TITLE := Netgear WGR614 v8
$(Device/netgear)
NETGEAR_BOARD_ID := U12H072T00_NETGEAR
NETGEAR_REGION := 2
@@ -409,6 +444,7 @@ endef
TARGET_DEVICES += netgear-wgr614-v8
define Device/netgear-wgt634u
+ DEVICE_TITLE := Netgear WGT634U
FILESYSTEMS := $(FS_128K)
IMAGES := bin
IMAGE/bin := trx-with-loader | prepend-with-elf
@@ -416,6 +452,7 @@ endef
TARGET_DEVICES += netgear-wgt634u
define Device/netgear-wndr3300-v1
+ DEVICE_TITLE := Netgear WNDR3300 v1
$(Device/netgear)
NETGEAR_BOARD_ID := U12H093T00_NETGEAR
NETGEAR_REGION := 2
@@ -423,6 +460,7 @@ endef
TARGET_DEVICES += netgear-wndr3300-v1
define Device/netgear-wnr834b-v2
+ DEVICE_TITLE := Netgear WNR834B v2
$(Device/netgear)
NETGEAR_BOARD_ID := U12H081T00_NETGEAR
NETGEAR_REGION := 2
@@ -430,6 +468,7 @@ endef
TARGET_DEVICES += netgear-wnr834b-v2
define Device/usrobotics-usr5461
+ DEVICE_TITLE := USRobotics USR5461
IMAGES := bin
IMAGE/bin := trx-with-loader | usrobotics-bin
endef
@@ -444,114 +483,133 @@ endif
ifeq ($(SUBTARGET),mips74k)
define Device/asus-rt-ac53u
+ DEVICE_TITLE := Asus RT-AC53U
$(Device/asus)
PRODUCTID := RT-AC53U
endef
TARGET_DEVICES += asus-rt-ac53u
define Device/asus-rt-ac66u
+ DEVICE_TITLE := Asus RT-AC66U
$(Device/asus)
PRODUCTID := RT-AC66U
endef
# TARGET_DEVICES += asus-rt-ac66u
define Device/asus-rt-n10
+ DEVICE_TITLE := Asus RT-N10
$(Device/asus)
PRODUCTID := "RT-N10 "
endef
TARGET_DEVICES += asus-rt-n10
define Device/asus-rt-n10p
+ DEVICE_TITLE := Asus RT-N10P
$(Device/asus)
PRODUCTID := RT-N10P
endef
TARGET_DEVICES += asus-rt-n10p
define Device/asus-rt-n10p-v2
+ DEVICE_TITLE := Asus RT-N10P v2
$(Device/asus)
PRODUCTID := RT-N10PV2
endef
TARGET_DEVICES += asus-rt-n10p-v2
define Device/asus-rt-n10u
+ DEVICE_TITLE := Asus RT-N10U
$(Device/asus)
PRODUCTID := RT-N10U
endef
TARGET_DEVICES += asus-rt-n10u
define Device/asus-rt-n10u-b
+ DEVICE_TITLE := Asus RT-N10U B
$(Device/asus)
PRODUCTID := RT-N10U
endef
TARGET_DEVICES += asus-rt-n10u-b
define Device/asus-rt-n12
+ DEVICE_TITLE := Asus RT-N12
$(Device/asus)
PRODUCTID := "RT-N12 "
endef
TARGET_DEVICES += asus-rt-n12
define Device/asus-rt-n12-b1
+ DEVICE_TITLE := Asus RT-N12 B1
$(Device/asus)
PRODUCTID := RT-N12B1
endef
TARGET_DEVICES += asus-rt-n12-b1
define Device/asus-rt-n12-c1
+ DEVICE_TITLE := Asus RT-N12 C1
$(Device/asus)
PRODUCTID := RT-N12C1
endef
TARGET_DEVICES += asus-rt-n12-c1
define Device/asus-rt-n12-d1
+ DEVICE_TITLE := Asus RT-N12 D1
$(Device/asus)
PRODUCTID := RT-N12D1
endef
TARGET_DEVICES += asus-rt-n12-d1
define Device/asus-rt-n12hp
+ DEVICE_TITLE := Asus RT-N12HP
$(Device/asus)
PRODUCTID := RT-N12HP
endef
TARGET_DEVICES += asus-rt-n12hp
define Device/asus-rt-n14uhp
+ DEVICE_TITLE := Asus RT-N14UHP
$(Device/asus)
PRODUCTID := RT-N14UHP
endef
TARGET_DEVICES += asus-rt-n14uhp
define Device/asus-rt-n15u
+ DEVICE_TITLE := Asus RT-N15U
$(Device/asus)
PRODUCTID := RT-N15U
endef
TARGET_DEVICES += asus-rt-n15u
define Device/asus-rt-n16
+ DEVICE_TITLE := Asus RT-N16
$(Device/asus)
PRODUCTID := RT-N16
endef
TARGET_DEVICES += asus-rt-n16
define Device/asus-rt-n53
+ DEVICE_TITLE := Asus RT-N53
$(Device/asus)
PRODUCTID := RT-N53
endef
TARGET_DEVICES += asus-rt-n53
define Device/asus-rt-n66u
+ DEVICE_TITLE := Asus RT-N66U
$(Device/asus)
PRODUCTID := RT-N66U
endef
TARGET_DEVICES += asus-rt-n66u
define Device/asus-rt-n66w
+ DEVICE_TITLE := Asus RT-N66W
$(Device/asus)
PRODUCTID := RT-N66U
endef
TARGET_DEVICES += asus-rt-n66w
define Device/linksys-wrt160n-v3
+ DEVICE_TITLE := Linksys WRT160N v3
$(Device/linksys)
DEVICE_ID := N150
VERSION := 3.0.3
@@ -559,6 +617,7 @@ endef
TARGET_DEVICES += linksys-wrt160n-v3
define Device/linksys-wrt310n-v2
+ DEVICE_TITLE := Linksys WRT310N v2
$(Device/linksys)
DEVICE_ID := 310N
VERSION := 2.0.1
@@ -566,6 +625,7 @@ endef
TARGET_DEVICES += linksys-wrt310n-v2
define Device/linksys-wrt320n-v1
+ DEVICE_TITLE := Linksys WRT320N v1
$(Device/linksys)
DEVICE_ID := 320N
VERSION := 1.0.5
@@ -573,6 +633,7 @@ endef
TARGET_DEVICES += linksys-wrt320n-v1
define Device/linksys-e900-v1
+ DEVICE_TITLE := Linksys E900 v1
$(Device/linksys)
DEVICE_ID := E900
VERSION := 1.0.4
@@ -580,6 +641,7 @@ endef
TARGET_DEVICES += linksys-e900-v1
define Device/linksys-e1000-v1-v2-v2.1
+ DEVICE_TITLE := Linksys E1000 v1 v2 v2.1
$(Device/linksys)
DEVICE_ID := E100
VERSION := 1.1.3
@@ -587,6 +649,7 @@ endef
TARGET_DEVICES += linksys-e1000-v1-v2-v2.1
define Device/linksys-e1200-v1
+ DEVICE_TITLE := Linksys E1200 v1
$(Device/linksys)
DEVICE_ID := E120
VERSION := 1.0.3
@@ -594,6 +657,7 @@ endef
TARGET_DEVICES += linksys-e1200-v1
define Device/linksys-e1200-v2
+ DEVICE_TITLE := Linksys E1200 v2
$(Device/linksys)
DEVICE_ID := E122
VERSION := 1.0.4
@@ -601,6 +665,7 @@ endef
TARGET_DEVICES += linksys-e1200-v2
define Device/linksys-e1500-v1
+ DEVICE_TITLE := Linksys E1500 v1
$(Device/linksys)
DEVICE_ID := E150
VERSION := 1.0.5
@@ -608,6 +673,7 @@ endef
TARGET_DEVICES += linksys-e1500-v1
define Device/linksys-e1550-v1
+ DEVICE_TITLE := Linksys E1550 v1
$(Device/linksys)
DEVICE_ID := 1550
VERSION := 1.0.3
@@ -615,6 +681,7 @@ endef
TARGET_DEVICES += linksys-e1550-v1
define Device/linksys-e2000-v1
+ DEVICE_TITLE := Linksys E2000 v1
$(Device/linksys)
DEVICE_ID := 32XN
VERSION := 1.0.4
@@ -622,6 +689,7 @@ endef
TARGET_DEVICES += linksys-e2000-v1
define Device/linksys-e2500-v1
+ DEVICE_TITLE := Linksys E2500 v1
$(Device/linksys)
DEVICE_ID := E25X
VERSION := 1.0.7
@@ -629,6 +697,7 @@ endef
TARGET_DEVICES += linksys-e2500-v1
define Device/linksys-e2500-v2
+ DEVICE_TITLE := Linksys E2500 v2
$(Device/linksys)
DEVICE_ID := E25X
VERSION := 2.0.0
@@ -636,6 +705,7 @@ endef
TARGET_DEVICES += linksys-e2500-v2
define Device/linksys-e2500-v2.1
+ DEVICE_TITLE := Linksys E2500 v2.1
$(Device/linksys)
DEVICE_ID := 25RU
VERSION := 2.1.0
@@ -643,6 +713,7 @@ endef
TARGET_DEVICES += linksys-e2500-v2.1
define Device/linksys-e2500-v3
+ DEVICE_TITLE := Linksys E2500 v3
$(Device/linksys)
DEVICE_ID := 25V3
VERSION := 3.0.0
@@ -650,6 +721,7 @@ endef
TARGET_DEVICES += linksys-e2500-v3
define Device/linksys-e3200-v1
+ DEVICE_TITLE := Linksys E3200 v1
$(Device/linksys)
DEVICE_ID := 3200
VERSION := 1.0.1
@@ -657,6 +729,7 @@ endef
TARGET_DEVICES += linksys-e3200-v1
define Device/linksys-e4200-v1
+ DEVICE_TITLE := Linksys E4200 v1
$(Device/linksys)
DEVICE_ID := 4200
VERSION := 1.0.5
@@ -664,6 +737,7 @@ endef
TARGET_DEVICES += linksys-e4200-v1
define Device/netgear-wgr614-v10_north-america
+ DEVICE_TITLE := Netgear WGR614 v10 North America
$(Device/netgear)
NETGEAR_BOARD_ID := U12H139T01_NETGEAR
NETGEAR_REGION := 2
@@ -671,6 +745,7 @@ endef
TARGET_DEVICES += netgear-wgr614-v10_north-america
define Device/netgear-wgr614-v10_other-regions
+ DEVICE_TITLE := Netgear WGR614 v10 Other Regions
$(Device/netgear)
NETGEAR_BOARD_ID := U12H139T01_NETGEAR
NETGEAR_REGION := 1
@@ -678,6 +753,7 @@ endef
TARGET_DEVICES += netgear-wgr614-v10_other-regions
define Device/netgear-wn2500rp-v1
+ DEVICE_TITLE := Netgear WN2500RP v1
$(Device/netgear)
NETGEAR_BOARD_ID := U12H197T00_NETGEAR
NETGEAR_REGION := 1
@@ -685,6 +761,7 @@ endef
TARGET_DEVICES += netgear-wn2500rp-v1
define Device/netgear-wndr3400-v1
+ DEVICE_TITLE := Netgear WNDR3400 v1
$(Device/netgear)
NETGEAR_BOARD_ID := U12H155T00_NETGEAR
NETGEAR_REGION := 2
@@ -692,6 +769,7 @@ endef
TARGET_DEVICES += netgear-wndr3400-v1
define Device/netgear-wndr3400-v2
+ DEVICE_TITLE := Netgear WNDR3400 v2
$(Device/netgear)
NETGEAR_BOARD_ID := U12H187T00_NETGEAR
NETGEAR_REGION := 2
@@ -699,6 +777,7 @@ endef
TARGET_DEVICES += netgear-wndr3400-v2
define Device/netgear-wndr3400-v3
+ DEVICE_TITLE := Netgear WNDR3400 v3
$(Device/netgear)
NETGEAR_BOARD_ID := U12H208T00_NETGEAR
NETGEAR_REGION := 1
@@ -706,6 +785,7 @@ endef
TARGET_DEVICES += netgear-wndr3400-v3
define Device/netgear-wndr3700-v3
+ DEVICE_TITLE := Netgear WNDR3700 v3
$(Device/netgear)
NETGEAR_BOARD_ID := U12H194T00_NETGEAR
NETGEAR_REGION := 2
@@ -713,6 +793,7 @@ endef
TARGET_DEVICES += netgear-wndr3700-v3
define Device/netgear-wndr3400-vcna
+ DEVICE_TITLE := Netgear WNDR3400 vcna
$(Device/netgear)
NETGEAR_BOARD_ID := U12H155T01_NETGEAR
NETGEAR_REGION := 2
@@ -720,6 +801,7 @@ endef
# TARGET_DEVICES += netgear-wndr3400-vcna
define Device/netgear-wndr4000
+ DEVICE_TITLE := Netgear WNDR4000
$(Device/netgear)
NETGEAR_BOARD_ID := U12H181T00_NETGEAR
NETGEAR_REGION := 2
@@ -727,6 +809,7 @@ endef
TARGET_DEVICES += netgear-wndr4000
define Device/netgear-wnr1000-v3
+ DEVICE_TITLE := Netgear WNR1000 v3
$(Device/netgear)
NETGEAR_BOARD_ID := U12H139T00_NETGEAR
NETGEAR_REGION := 2
@@ -734,6 +817,7 @@ endef
TARGET_DEVICES += netgear-wnr1000-v3
define Device/netgear-wnr2000v2
+ DEVICE_TITLE := Netgear WNR2000 v2
$(Device/netgear)
NETGEAR_BOARD_ID := U12H114T00_NETGEAR
NETGEAR_REGION := 2
@@ -741,6 +825,7 @@ endef
TARGET_DEVICES += netgear-wnr2000v2
define Device/netgear-wnr3000rp
+ DEVICE_TITLE := Netgear WNR3000RP
$(Device/netgear)
NETGEAR_BOARD_ID := U12H163T01_NETGEAR
NETGEAR_REGION := 1
@@ -748,6 +833,7 @@ endef
TARGET_DEVICES += netgear-wnr3000rp
define Device/netgear-wnr3500l-v1-north-america
+ DEVICE_TITLE := Netgear WNR3500L v1 North America
$(Device/netgear)
NETGEAR_BOARD_ID := U12H136T99_NETGEAR
NETGEAR_REGION := 2
@@ -755,6 +841,7 @@ endef
TARGET_DEVICES += netgear-wnr3500l-v1-north-america
define Device/netgear-wnr3500l-v1-other-regions
+ DEVICE_TITLE := Netgear WNR3500L v1 Other Regions
$(Device/netgear)
NETGEAR_BOARD_ID := U12H136T99_NETGEAR
NETGEAR_REGION := 1
@@ -762,6 +849,7 @@ endef
TARGET_DEVICES += netgear-wnr3500l-v1-other-regions
define Device/netgear-wnr3500l-v2
+ DEVICE_TITLE := Netgear WNR3500L v2
$(Device/netgear)
NETGEAR_BOARD_ID := U12H172T00_NETGEAR
NETGEAR_REGION := 1
@@ -769,6 +857,7 @@ endef
TARGET_DEVICES += netgear-wnr3500l-v2
define Device/netgear-wnr3500u
+ DEVICE_TITLE := Netgear WNR3500U
$(Device/netgear)
NETGEAR_BOARD_ID := U12H136T00_NETGEAR
NETGEAR_REGION := 2
@@ -776,6 +865,7 @@ endef
# TARGET_DEVICES += netgear-wnr3500u
define Device/netgear-wnr3500-v2
+ DEVICE_TITLE := Netgear WNR3500 v2
$(Device/netgear)
NETGEAR_BOARD_ID := U12H127T00_NETGEAR
NETGEAR_REGION := 2
@@ -783,6 +873,7 @@ endef
TARGET_DEVICES += netgear-wnr3500-v2
define Device/netgear-wnr3500-v2-vc
+ DEVICE_TITLE := Netgear WNR3500 v2 vc
$(Device/netgear)
NETGEAR_BOARD_ID := U12H127T70_NETGEAR
NETGEAR_REGION := 2