aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/brcm47xx
diff options
context:
space:
mode:
authorRafał Miłecki <rafal@milecki.pl>2016-10-28 16:43:19 +0200
committerRafał Miłecki <rafal@milecki.pl>2016-10-28 16:46:57 +0200
commit027b2c5b83e1ce7f9226e21c93e08ffe9c38a552 (patch)
treed9a13272bdc737ee4ba04a866270c2d95e6bc4e3 /target/linux/brcm47xx
parent8bd21672364e44cecebb8aef27041e6c607addaa (diff)
downloadupstream-027b2c5b83e1ce7f9226e21c93e08ffe9c38a552.tar.gz
upstream-027b2c5b83e1ce7f9226e21c93e08ffe9c38a552.tar.bz2
upstream-027b2c5b83e1ce7f9226e21c93e08ffe9c38a552.zip
brcm47xx: image: make TRX steps work with rootfs passed as $@
Signed-off-by: Rafał Miłecki <rafal@milecki.pl>
Diffstat (limited to 'target/linux/brcm47xx')
-rw-r--r--target/linux/brcm47xx/image/Makefile6
1 files changed, 4 insertions, 2 deletions
diff --git a/target/linux/brcm47xx/image/Makefile b/target/linux/brcm47xx/image/Makefile
index 84e70051a4..2c79ab0b1a 100644
--- a/target/linux/brcm47xx/image/Makefile
+++ b/target/linux/brcm47xx/image/Makefile
@@ -51,10 +51,11 @@ endef
define Build/trx-with-loader
$(STAGING_DIR_HOST)/bin/trx \
-m 33554432 \
- -o $@ \
+ -o $@.new \
-f $(KDIR)/loader.gz \
-f $(IMAGE_KERNEL) \
$(call trxalign/$(FILESYSTEM),$(FILESYSTEM))
+ mv $@.new $@
endef
define Build/trx-v2-with-loader
@@ -71,9 +72,10 @@ endef
define Build/trx-without-loader
$(STAGING_DIR_HOST)/bin/trx \
-m 33554432 \
- -o $@ \
+ -o $@.new \
-f $(IMAGE_KERNEL) \
$(call trxalign/$(FILESYSTEM),$(FILESYSTEM))
+ mv $@.new $@
endef
define Build/asus-trx