aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/brcm47xx
diff options
context:
space:
mode:
authorHauke Mehrtens <hauke@openwrt.org>2014-07-06 17:14:06 +0000
committerHauke Mehrtens <hauke@openwrt.org>2014-07-06 17:14:06 +0000
commit769e2bac54f1612bda0e26f03d262935aaef622a (patch)
tree172a2a1f4679c515957bc3938957c99d3ab08af3 /target/linux/brcm47xx
parentebf712921a432b7a46a990063094ffb1adac2d7f (diff)
downloadupstream-769e2bac54f1612bda0e26f03d262935aaef622a.tar.gz
upstream-769e2bac54f1612bda0e26f03d262935aaef622a.tar.bz2
upstream-769e2bac54f1612bda0e26f03d262935aaef622a.zip
brcm47xx: image: prepare for using mips74k subtarget
Signed-off-by: Rafał Miłecki <zajec5@gmail.com> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@41528 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/brcm47xx')
-rw-r--r--target/linux/brcm47xx/image/Makefile20
1 files changed, 20 insertions, 0 deletions
diff --git a/target/linux/brcm47xx/image/Makefile b/target/linux/brcm47xx/image/Makefile
index 9f06e0f541..a5c7240c97 100644
--- a/target/linux/brcm47xx/image/Makefile
+++ b/target/linux/brcm47xx/image/Makefile
@@ -164,6 +164,26 @@ define Image/Build/generic/squashfs
endef
#################################################
+# Subtarget mips74k
+#################################################
+
+# $(1): filesystem type.
+define Image/Build/mips74k/jffs2-64k
+ $(call Image/Build/mips74k/devices-with-64k-blocks,$(1))
+endef
+
+# $(1): filesystem type.
+define Image/Build/mips74k/jffs2-128k
+ $(call Image/Build/mips74k/devices-with-128k-blocks,$(1))
+endef
+
+# $(1): filesystem type.
+define Image/Build/mips74k/squashfs
+ $(call Image/Build/mips74k/devices-with-64k-blocks,$(1))
+ $(call Image/Build/mips74k/devices-with-128k-blocks,$(1))
+endef
+
+#################################################
# Shared BuildImage defines
#################################################