aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/brcm47xx
diff options
context:
space:
mode:
authorJonas Gorski <jogo@openwrt.org>2012-01-31 09:43:53 +0000
committerJonas Gorski <jogo@openwrt.org>2012-01-31 09:43:53 +0000
commitdb12fa60c6b0ba455c89c7c45fb89b0fe6bca1ad (patch)
tree57e6d449401b70ffb3b1c06d8ccc677b1b08efdf /target/linux/brcm47xx
parent61579d09346cf8b42ae0550359de62a3d31ba99d (diff)
downloadupstream-db12fa60c6b0ba455c89c7c45fb89b0fe6bca1ad.tar.gz
upstream-db12fa60c6b0ba455c89c7c45fb89b0fe6bca1ad.tar.bz2
upstream-db12fa60c6b0ba455c89c7c45fb89b0fe6bca1ad.zip
kernel: update linux 3.0 to 3.0.18
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@29965 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/brcm47xx')
-rw-r--r--target/linux/brcm47xx/Makefile2
-rw-r--r--target/linux/brcm47xx/patches-3.0/0045-ssb-fix-cardbus-in-hostmode.patch4
2 files changed, 3 insertions, 3 deletions
diff --git a/target/linux/brcm47xx/Makefile b/target/linux/brcm47xx/Makefile
index 8f3362a870..0212ee6806 100644
--- a/target/linux/brcm47xx/Makefile
+++ b/target/linux/brcm47xx/Makefile
@@ -11,7 +11,7 @@ BOARD:=brcm47xx
BOARDNAME:=Broadcom BCM947xx/953xx
FEATURES:=squashfs usb pcmcia
-LINUX_VERSION:=3.0.17
+LINUX_VERSION:=3.0.18
include $(INCLUDE_DIR)/target.mk
DEFAULT_PACKAGES += wpad-mini kmod-switch kmod-diag nvram
diff --git a/target/linux/brcm47xx/patches-3.0/0045-ssb-fix-cardbus-in-hostmode.patch b/target/linux/brcm47xx/patches-3.0/0045-ssb-fix-cardbus-in-hostmode.patch
index 4837fe740f..0a329c00a3 100644
--- a/target/linux/brcm47xx/patches-3.0/0045-ssb-fix-cardbus-in-hostmode.patch
+++ b/target/linux/brcm47xx/patches-3.0/0045-ssb-fix-cardbus-in-hostmode.patch
@@ -11,7 +11,7 @@ Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
--- a/drivers/ssb/driver_pcicore.c
+++ b/drivers/ssb/driver_pcicore.c
-@@ -75,7 +75,7 @@ static u32 get_cfgspace_addr(struct ssb_
+@@ -74,7 +74,7 @@ static u32 get_cfgspace_addr(struct ssb_
u32 tmp;
/* We do only have one cardbus device behind the bridge. */
@@ -19,4 +19,4 @@ Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
+ if (pc->cardbusmode && (dev > 1))
goto out;
- /* Type 0 transaction */
+ if (bus == 0) {