aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/brcm47xx/profiles/220-Broadcom-bgmac-b43.mk
diff options
context:
space:
mode:
authorHauke Mehrtens <hauke@openwrt.org>2013-01-24 14:38:10 +0000
committerHauke Mehrtens <hauke@openwrt.org>2013-01-24 14:38:10 +0000
commit25ebb1738fad3d0ca53027c985b2a2886804af2d (patch)
treec5689a597591396e3f99bace70906c4bd4c3e291 /target/linux/brcm47xx/profiles/220-Broadcom-bgmac-b43.mk
parent264698349696d8b3ec93c8f476e084c5aca0b00c (diff)
downloadupstream-25ebb1738fad3d0ca53027c985b2a2886804af2d.tar.gz
upstream-25ebb1738fad3d0ca53027c985b2a2886804af2d.tar.bz2
upstream-25ebb1738fad3d0ca53027c985b2a2886804af2d.zip
brcm47xx: change generic profiles
The default profile now contains Ethernet drivers for all the types found on supported boards. There are other profiles for each Ethernet driver. git-svn-id: svn://svn.openwrt.org/openwrt/trunk@35314 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/brcm47xx/profiles/220-Broadcom-bgmac-b43.mk')
-rw-r--r--target/linux/brcm47xx/profiles/220-Broadcom-bgmac-b43.mk20
1 files changed, 20 insertions, 0 deletions
diff --git a/target/linux/brcm47xx/profiles/220-Broadcom-bgmac-b43.mk b/target/linux/brcm47xx/profiles/220-Broadcom-bgmac-b43.mk
new file mode 100644
index 0000000000..70cd8890a9
--- /dev/null
+++ b/target/linux/brcm47xx/profiles/220-Broadcom-bgmac-b43.mk
@@ -0,0 +1,20 @@
+#
+# Copyright (C) 2007-2013 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/Broadcom-bgmac-b43
+ NAME:=Broadcom SoC, bgmac Ethernet, BCM43xx WiFi (bgmac)
+ PACKAGES:=kmod-bgmac kmod-b43
+endef
+
+define Profile/Broadcom-bgmac-b43/Description
+ Package set compatible with hardware newer Broadcom BCM47xx or BCM535x
+ SoC with Broadcom BCM43xx Wifi cards using the mac80211 and b43
+ drivers and bgmac Ethernet driver.
+endef
+
+$(eval $(call Profile,Broadcom-bgmac-b43))
+