aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/brcm47xx/profiles/204-Broadcom-b44-ath5k.mk
diff options
context:
space:
mode:
authorHauke Mehrtens <hauke@hauke-m.de>2013-01-24 14:38:10 +0000
committerHauke Mehrtens <hauke@hauke-m.de>2013-01-24 14:38:10 +0000
commit76c12ff797c49940741b107d7b09dc1bdd350670 (patch)
tree5927fec65ee6daf8adcf5680211e9dfdc2c3f62c /target/linux/brcm47xx/profiles/204-Broadcom-b44-ath5k.mk
parentb60fc82ce5a7ea7a462d44412c9f96e138bfbd4f (diff)
downloadupstream-76c12ff797c49940741b107d7b09dc1bdd350670.tar.gz
upstream-76c12ff797c49940741b107d7b09dc1bdd350670.tar.bz2
upstream-76c12ff797c49940741b107d7b09dc1bdd350670.zip
brcm47xx: change generic profiles
The default profile now contains Ethernet drivers for all the types found on supported boards. There are other profiles for each Ethernet driver. SVN-Revision: 35314
Diffstat (limited to 'target/linux/brcm47xx/profiles/204-Broadcom-b44-ath5k.mk')
-rw-r--r--target/linux/brcm47xx/profiles/204-Broadcom-b44-ath5k.mk19
1 files changed, 19 insertions, 0 deletions
diff --git a/target/linux/brcm47xx/profiles/204-Broadcom-b44-ath5k.mk b/target/linux/brcm47xx/profiles/204-Broadcom-b44-ath5k.mk
new file mode 100644
index 0000000000..55d729a5b7
--- /dev/null
+++ b/target/linux/brcm47xx/profiles/204-Broadcom-b44-ath5k.mk
@@ -0,0 +1,19 @@
+#
+# Copyright (C) 2006-2013 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/Broadcom-b44-ath5k
+ NAME:=Broadcom SoC, b44 Ethernet, Atheros WiFi (ath5k)
+ PACKAGES:=kmod-b44 kmod-ath5k
+endef
+
+define Profile/Broadcom-b44-ath5k/Description
+ Package set compatible with hardware older Broadcom BCM47xx or BCM535x
+ SoC with Atheros Wifi cards using the mac80211 and ath5k drivers and
+ b44 Ethernet driver.
+endef
+$(eval $(call Profile,Broadcom-b44-ath5k))
+