aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/brcm47xx/patches-3.10/820-wgt634u-nvram-fix.patch
diff options
context:
space:
mode:
authorHauke Mehrtens <hauke@hauke-m.de>2014-06-07 17:04:37 +0000
committerHauke Mehrtens <hauke@hauke-m.de>2014-06-07 17:04:37 +0000
commit717e8b6f3c994ca6e13d02b9a175725e0e887b99 (patch)
tree9db889826450b8840e476013cd83af0839fcf3c2 /target/linux/brcm47xx/patches-3.10/820-wgt634u-nvram-fix.patch
parent1714048d7f8dcf01ba134a8c4cc414240da1c40d (diff)
downloadupstream-717e8b6f3c994ca6e13d02b9a175725e0e887b99.tar.gz
upstream-717e8b6f3c994ca6e13d02b9a175725e0e887b99.tar.bz2
upstream-717e8b6f3c994ca6e13d02b9a175725e0e887b99.zip
brcm47xx: remove old gpio and nvram interfaces
These were only used by broadcom-diag any more. Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de> SVN-Revision: 41048
Diffstat (limited to 'target/linux/brcm47xx/patches-3.10/820-wgt634u-nvram-fix.patch')
-rw-r--r--target/linux/brcm47xx/patches-3.10/820-wgt634u-nvram-fix.patch14
1 files changed, 2 insertions, 12 deletions
diff --git a/target/linux/brcm47xx/patches-3.10/820-wgt634u-nvram-fix.patch b/target/linux/brcm47xx/patches-3.10/820-wgt634u-nvram-fix.patch
index 4cf6ee0832..f666cf36ca 100644
--- a/target/linux/brcm47xx/patches-3.10/820-wgt634u-nvram-fix.patch
+++ b/target/linux/brcm47xx/patches-3.10/820-wgt634u-nvram-fix.patch
@@ -5,10 +5,10 @@ out the configuration than the in kernel cfe config reader.
--- a/arch/mips/bcm47xx/Makefile
+++ b/arch/mips/bcm47xx/Makefile
-@@ -6,3 +6,4 @@
+@@ -5,3 +5,4 @@
+
obj-y += irq.o nvram.o prom.o serial.o setup.o time.o sprom.o
obj-y += board.o buttons.o leds.o workarounds.o
- obj-y += gpio.o
+obj-y += cfe_env.o
--- /dev/null
+++ b/arch/mips/bcm47xx/cfe_env.c
@@ -294,13 +294,3 @@ out the configuration than the in kernel cfe config reader.
/* Look for name=value and return value */
var = &nvram_buf[sizeof(struct nvram_header)];
end = nvram_buf + sizeof(nvram_buf) - 2;
-@@ -221,6 +250,9 @@ char *nvram_get(const char *name)
- if (!nvram_buf[0])
- nvram_init();
-
-+ if (cfe_env)
-+ return cfe_env_get(nvram_buf, name);
-+
- /* Look for name=value and return value */
- var = &nvram_buf[sizeof(struct nvram_header)];
- end = nvram_buf + sizeof(nvram_buf) - 2;