aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/brcm47xx/patches-3.0/110-flash_map.patch
diff options
context:
space:
mode:
authorHauke Mehrtens <hauke@hauke-m.de>2011-06-18 15:24:44 +0000
committerHauke Mehrtens <hauke@hauke-m.de>2011-06-18 15:24:44 +0000
commit75f9e0c615d2fe50259ac6bc96e2b849fc975ea7 (patch)
treef0dc7985c9d6b4d5249e51c4a2371fe84806235d /target/linux/brcm47xx/patches-3.0/110-flash_map.patch
parent2e1b73912d4eb749901c4f0ab248b64339895cb1 (diff)
downloadupstream-75f9e0c615d2fe50259ac6bc96e2b849fc975ea7.tar.gz
upstream-75f9e0c615d2fe50259ac6bc96e2b849fc975ea7.tar.bz2
upstream-75f9e0c615d2fe50259ac6bc96e2b849fc975ea7.zip
brcm47xx: add support for kernel 3.0
SVN-Revision: 27217
Diffstat (limited to 'target/linux/brcm47xx/patches-3.0/110-flash_map.patch')
-rw-r--r--target/linux/brcm47xx/patches-3.0/110-flash_map.patch25
1 files changed, 25 insertions, 0 deletions
diff --git a/target/linux/brcm47xx/patches-3.0/110-flash_map.patch b/target/linux/brcm47xx/patches-3.0/110-flash_map.patch
new file mode 100644
index 0000000000..02fd5e67b0
--- /dev/null
+++ b/target/linux/brcm47xx/patches-3.0/110-flash_map.patch
@@ -0,0 +1,25 @@
+--- a/drivers/mtd/maps/Kconfig
++++ b/drivers/mtd/maps/Kconfig
+@@ -332,6 +332,12 @@ config MTD_CFI_FLAGADM
+ Mapping for the Flaga digital module. If you don't have one, ignore
+ this setting.
+
++config MTD_BCM47XX
++ tristate "BCM47xx flash device"
++ depends on MIPS && MTD_CFI && BCM47XX
++ help
++ Support for the flash chips on the BCM947xx board.
++
+ config MTD_SOLUTIONENGINE
+ tristate "CFI Flash device mapped on Hitachi SolutionEngine"
+ depends on SUPERH && SOLUTION_ENGINE && MTD_CFI && MTD_REDBOOT_PARTS
+--- a/drivers/mtd/maps/Makefile
++++ b/drivers/mtd/maps/Makefile
+@@ -28,6 +28,7 @@ obj-$(CONFIG_MTD_PMC_MSP_EVM) += pmcms
+ obj-$(CONFIG_MTD_PCMCIA) += pcmciamtd.o
+ obj-$(CONFIG_MTD_RPXLITE) += rpxlite.o
+ obj-$(CONFIG_MTD_TQM8XXL) += tqm8xxl.o
++obj-$(CONFIG_MTD_BCM47XX) += bcm47xx-flash.o
+ obj-$(CONFIG_MTD_SA1100) += sa1100-flash.o
+ obj-$(CONFIG_MTD_SBC_GXX) += sbc_gxx.o
+ obj-$(CONFIG_MTD_SC520CDP) += sc520cdp.o