aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/brcm47xx/patches-2.6.37/110-flash_map.patch
diff options
context:
space:
mode:
authorAlexandros C. Couloumbis <alex@ozo.com>2010-11-10 19:01:07 +0000
committerAlexandros C. Couloumbis <alex@ozo.com>2010-11-10 19:01:07 +0000
commit9c90dce82802de88669b7dd41425dd4bdde3c0c9 (patch)
tree5dae20befd028042840a11da0fb0cd36ad274fee /target/linux/brcm47xx/patches-2.6.37/110-flash_map.patch
parent283e5476068c9072e4416e0b3181be2a3c5f2a93 (diff)
downloadupstream-9c90dce82802de88669b7dd41425dd4bdde3c0c9.tar.gz
upstream-9c90dce82802de88669b7dd41425dd4bdde3c0c9.tar.bz2
upstream-9c90dce82802de88669b7dd41425dd4bdde3c0c9.zip
linux/brcm47xx: add preliminary 2.6.37 kernel support
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@23945 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/brcm47xx/patches-2.6.37/110-flash_map.patch')
-rw-r--r--target/linux/brcm47xx/patches-2.6.37/110-flash_map.patch25
1 files changed, 25 insertions, 0 deletions
diff --git a/target/linux/brcm47xx/patches-2.6.37/110-flash_map.patch b/target/linux/brcm47xx/patches-2.6.37/110-flash_map.patch
new file mode 100644
index 0000000000..502141b1f0
--- /dev/null
+++ b/target/linux/brcm47xx/patches-2.6.37/110-flash_map.patch
@@ -0,0 +1,25 @@
+--- a/drivers/mtd/maps/Kconfig
++++ b/drivers/mtd/maps/Kconfig
+@@ -328,6 +328,12 @@ config MTD_CFI_FLAGADM
+ Mapping for the Flaga digital module. If you don't have one, ignore
+ this setting.
+
++config MTD_BCM47XX
++ tristate "BCM47xx flash device"
++ depends on MIPS && MTD_CFI && BCM47XX
++ help
++ Support for the flash chips on the BCM947xx board.
++
+ config MTD_SOLUTIONENGINE
+ tristate "CFI Flash device mapped on Hitachi SolutionEngine"
+ depends on SUPERH && SOLUTION_ENGINE && MTD_CFI && MTD_REDBOOT_PARTS
+--- a/drivers/mtd/maps/Makefile
++++ b/drivers/mtd/maps/Makefile
+@@ -29,6 +29,7 @@ obj-$(CONFIG_MTD_PMC_MSP_EVM) += pmcms
+ obj-$(CONFIG_MTD_PCMCIA) += pcmciamtd.o
+ obj-$(CONFIG_MTD_RPXLITE) += rpxlite.o
+ obj-$(CONFIG_MTD_TQM8XXL) += tqm8xxl.o
++obj-$(CONFIG_MTD_BCM47XX) += bcm47xx-flash.o
+ obj-$(CONFIG_MTD_SA1100) += sa1100-flash.o
+ obj-$(CONFIG_MTD_SBC_GXX) += sbc_gxx.o
+ obj-$(CONFIG_MTD_SC520CDP) += sc520cdp.o