aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/brcm47xx/patches-2.6.28/815-watchdog.patch
diff options
context:
space:
mode:
authorHauke Mehrtens <hauke@hauke-m.de>2009-06-14 09:45:59 +0000
committerHauke Mehrtens <hauke@hauke-m.de>2009-06-14 09:45:59 +0000
commitaf0d813825c2396e947b8dbefedcb604c522f53f (patch)
tree552e2c81bd95497585742acc666d152430bd1116 /target/linux/brcm47xx/patches-2.6.28/815-watchdog.patch
parent567b6d1a271d901aa381e70b2060bacfbc51bd50 (diff)
downloadupstream-af0d813825c2396e947b8dbefedcb604c522f53f.tar.gz
upstream-af0d813825c2396e947b8dbefedcb604c522f53f.tar.bz2
upstream-af0d813825c2396e947b8dbefedcb604c522f53f.zip
refresh patches
SVN-Revision: 16445
Diffstat (limited to 'target/linux/brcm47xx/patches-2.6.28/815-watchdog.patch')
-rw-r--r--target/linux/brcm47xx/patches-2.6.28/815-watchdog.patch22
1 files changed, 8 insertions, 14 deletions
diff --git a/target/linux/brcm47xx/patches-2.6.28/815-watchdog.patch b/target/linux/brcm47xx/patches-2.6.28/815-watchdog.patch
index 9d566ae8d8..f524d8c14e 100644
--- a/target/linux/brcm47xx/patches-2.6.28/815-watchdog.patch
+++ b/target/linux/brcm47xx/patches-2.6.28/815-watchdog.patch
@@ -10,11 +10,9 @@ be build as a module.
Signed-off-by: Aleksandar Radovanovic <biblbroks@sezampro.rs>
Signed-off-by: Matthieu CASTET <castet.matthieu@free.fr>
-Index: linux-2.6/drivers/watchdog/Kconfig
-===================================================================
---- linux-2.6.orig/drivers/watchdog/Kconfig 2009-05-25 22:22:02.000000000 +0200
-+++ linux-2.6/drivers/watchdog/Kconfig 2009-06-05 22:05:19.000000000 +0200
-@@ -764,6 +764,12 @@
+--- a/drivers/watchdog/Kconfig
++++ b/drivers/watchdog/Kconfig
+@@ -747,6 +747,12 @@ config TXX9_WDT
help
Hardware driver for the built-in watchdog timer on TXx9 MIPS SoCs.
@@ -27,11 +25,9 @@ Index: linux-2.6/drivers/watchdog/Kconfig
# PARISC Architecture
# POWERPC Architecture
-Index: linux-2.6/drivers/watchdog/Makefile
-===================================================================
---- linux-2.6.orig/drivers/watchdog/Makefile 2009-05-25 22:22:02.000000000 +0200
-+++ linux-2.6/drivers/watchdog/Makefile 2009-05-25 23:02:27.000000000 +0200
-@@ -105,6 +105,7 @@
+--- a/drivers/watchdog/Makefile
++++ b/drivers/watchdog/Makefile
+@@ -106,6 +106,7 @@ obj-$(CONFIG_WDT_RM9K_GPI) += rm9k_wdt.o
obj-$(CONFIG_SIBYTE_WDOG) += sb_wdog.o
obj-$(CONFIG_AR7_WDT) += ar7_wdt.o
obj-$(CONFIG_TXX9_WDT) += txx9wdt.o
@@ -39,10 +35,8 @@ Index: linux-2.6/drivers/watchdog/Makefile
# PARISC Architecture
-Index: linux-2.6/drivers/watchdog/bcm47xx_wdt.c
-===================================================================
---- /dev/null 1970-01-01 00:00:00.000000000 +0000
-+++ linux-2.6/drivers/watchdog/bcm47xx_wdt.c 2009-06-05 22:25:37.000000000 +0200
+--- /dev/null
++++ b/drivers/watchdog/bcm47xx_wdt.c
@@ -0,0 +1,286 @@
+/*
+ * Watchdog driver for Broadcom BCM47XX