aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/brcm47xx/legacy/profiles/100-Broadcom-b43.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2014-06-07 15:19:40 +0000
committerFelix Fietkau <nbd@openwrt.org>2014-06-07 15:19:40 +0000
commitdec0d7f025c104f85fafe8c5f47dcb52df17b5b9 (patch)
tree0ff07a3453876845a934a495f57c9b8315aec9cb /target/linux/brcm47xx/legacy/profiles/100-Broadcom-b43.mk
parent8b4dd24444aede8b8b4fc6706b9d32459d1300fb (diff)
downloadupstream-dec0d7f025c104f85fafe8c5f47dcb52df17b5b9.tar.gz
upstream-dec0d7f025c104f85fafe8c5f47dcb52df17b5b9.tar.bz2
upstream-dec0d7f025c104f85fafe8c5f47dcb52df17b5b9.zip
brcm47xx: add a "legacy" subtarget that is usable for low-end 802.11g devices like WRT54G
Signed-off-by: Felix Fietkau <nbd@openwrt.org> SVN-Revision: 41041
Diffstat (limited to 'target/linux/brcm47xx/legacy/profiles/100-Broadcom-b43.mk')
-rw-r--r--target/linux/brcm47xx/legacy/profiles/100-Broadcom-b43.mk20
1 files changed, 20 insertions, 0 deletions
diff --git a/target/linux/brcm47xx/legacy/profiles/100-Broadcom-b43.mk b/target/linux/brcm47xx/legacy/profiles/100-Broadcom-b43.mk
new file mode 100644
index 0000000000..50d777010b
--- /dev/null
+++ b/target/linux/brcm47xx/legacy/profiles/100-Broadcom-b43.mk
@@ -0,0 +1,20 @@
+#
+# Copyright (C) 2007-2013 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/Broadcom-b43
+ NAME:=Broadcom SoC, all Ethernet, BCM43xx WiFi (b43, default)
+ PACKAGES:=kmod-b43 kmod-b43legacy
+endef
+
+define Profile/Broadcom-b43/Description
+ Package set compatible with hardware any Broadcom BCM47xx or BCM535x
+ SoC with Broadcom BCM43xx Wifi cards using the mac80211, b43 and
+ b43legacy drivers and b44, tg3 or bgmac Ethernet driver.
+endef
+
+$(eval $(call Profile,Broadcom-b43))
+