aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/brcm47xx/image/Makefile
diff options
context:
space:
mode:
authorRafał Miłecki <zajec5@gmail.com>2016-03-11 08:54:03 +0000
committerRafał Miłecki <zajec5@gmail.com>2016-03-11 08:54:03 +0000
commit0683576eac9a7d579be694d9318001245679fe0d (patch)
treec22d79d3fe86e28326dc78fedf59e38371b661ca /target/linux/brcm47xx/image/Makefile
parentfb51a409925b70d4203409b494f4054c90d45450 (diff)
downloadupstream-0683576eac9a7d579be694d9318001245679fe0d.tar.gz
upstream-0683576eac9a7d579be694d9318001245679fe0d.tar.bz2
upstream-0683576eac9a7d579be694d9318001245679fe0d.zip
brcm47xx: image: switch D-Link DWL-3150 to the new building system
Signed-off-by: Rafał Miłecki <zajec5@gmail.com> Backport of r48970 git-svn-id: svn://svn.openwrt.org/openwrt/branches/chaos_calmer@48998 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/brcm47xx/image/Makefile')
-rw-r--r--target/linux/brcm47xx/image/Makefile20
1 files changed, 13 insertions, 7 deletions
diff --git a/target/linux/brcm47xx/image/Makefile b/target/linux/brcm47xx/image/Makefile
index 4e1c6642c1..1051acf256 100644
--- a/target/linux/brcm47xx/image/Makefile
+++ b/target/linux/brcm47xx/image/Makefile
@@ -1,5 +1,5 @@
#
-# Copyright (C) 2006-2012 OpenWrt.org
+# Copyright (C) 2006-2016 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
@@ -39,11 +39,6 @@ define Image/Build/wgt634u
cat $(BIN_DIR)/$(IMG_PREFIX)-$(1).trx >> $(BIN_DIR)/$(IMG_PREFIX)-wgt634u-$(2).bin
endef
-define Image/Build/dwl3150
- cp $(BIN_DIR)/$(IMG_PREFIX)-$(1).trx $(BIN_DIR)/$(IMG_PREFIX)-dwl3150-$(2).bin
- echo "BCM-5352-2050-0000000-01" >> $(BIN_DIR)/$(IMG_PREFIX)-dwl3150-$(2).bin
-endef
-
# $(1): filesystem type.
# $(2): device model (used for output file).
# $(3): pattern (device specific magic).
@@ -135,6 +130,10 @@ define Build/netgear-chk
mv $@.new $@
endef
+define Build/tailed-bin
+ echo $(BIN_TAIL) >> $@
+endef
+
#################################################
# Devices
#################################################
@@ -142,6 +141,7 @@ endef
DEVICE_VARS += PRODUCTID
DEVICE_VARS += DEVICE_ID VERSION
DEVICE_VARS += BOARD_ID REGION
+DEVICE_VARS += BIN_TAIL
define Device/Default
KERNEL := kernel-bin
@@ -221,7 +221,6 @@ endef
# $(1): filesystem type.
define Image/Build/legacy/devices-with-64k-blocks
- $(call Image/Build/dwl3150,$(1),$(patsubst jffs2-%,jffs2,$(1)))
$(call Image/Build/Edi,$(1),ps1208mfg,$(patsubst jffs2-%,jffs2,$(1)))
$(call Image/Build/Huawei,$(1),e970,$(1))
$(call Image/Build/Motorola,$(1),wa840g,2,$(patsubst jffs2-%,jffs2,$(1)))
@@ -246,6 +245,12 @@ define Image/Build/legacy/squashfs
$(call Image/Build/legacy/devices-with-128k-blocks,$(1))
endef
+define Device/dlink-dwl-3150
+ IMAGES := bin
+ IMAGE/bin := trx-with-loader | tailed-bin
+ BIN_TAIL := BCM-5352-2050-0000000-01
+endef
+
define Device/linksys-wrt54gs
$(Device/linksys)
FILESYSTEMS := $(FS_128K)
@@ -262,6 +267,7 @@ endef
ifeq ($(SUBTARGET),legacy)
TARGET_DEVICES += \
+ dlink-dwl-3150 \
linksys-wrt54gs \
linksys-wrtsl54gs