aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/brcm47xx/generic
diff options
context:
space:
mode:
authorAdrian Schmutzler <freifunk@adrianschmutzler.de>2020-02-07 15:42:54 +0100
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>2020-02-14 14:10:51 +0100
commit8fe5ad5d3373cebed4fbc55a7b779721971ce427 (patch)
tree5d9106ede800508dde24c21dda7f90b8b1b8af5b /target/linux/brcm47xx/generic
parent8590e70fab64172700c21bc5e658eba17a1eae70 (diff)
downloadupstream-8fe5ad5d3373cebed4fbc55a7b779721971ce427.tar.gz
upstream-8fe5ad5d3373cebed4fbc55a7b779721971ce427.tar.bz2
upstream-8fe5ad5d3373cebed4fbc55a7b779721971ce427.zip
brcm47xx: rename target to bcm47xx
This change makes the names of Broadcom targets consistent by using the common notation based on SoC/CPU ID (which is used internally anyway), bcmXXXX instead of brcmXXXX. This is even used for target TITLE in make menuconfig already, only the short target name used brcm so far. Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
Diffstat (limited to 'target/linux/brcm47xx/generic')
-rw-r--r--target/linux/brcm47xx/generic/profiles/100-Broadcom-b43.mk20
-rw-r--r--target/linux/brcm47xx/generic/profiles/101-Broadcom-wl.mk20
-rw-r--r--target/linux/brcm47xx/generic/profiles/104-Broadcom-ath5k.mk19
-rw-r--r--target/linux/brcm47xx/generic/profiles/105-Broadcom-none.mk18
-rw-r--r--target/linux/brcm47xx/generic/profiles/200-Broadcom-b44-b43.mk20
-rw-r--r--target/linux/brcm47xx/generic/profiles/201-Broadcom-b44-wl.mk20
-rw-r--r--target/linux/brcm47xx/generic/profiles/204-Broadcom-b44-ath5k.mk19
-rw-r--r--target/linux/brcm47xx/generic/profiles/205-Broadcom-b44-none.mk18
-rw-r--r--target/linux/brcm47xx/generic/profiles/210-Broadcom-tg3-b43.mk20
-rw-r--r--target/linux/brcm47xx/generic/profiles/211-Broadcom-tg3-wl.mk20
-rw-r--r--target/linux/brcm47xx/generic/profiles/215-Broadcom-tg3-none.mk18
-rw-r--r--target/linux/brcm47xx/generic/profiles/220-Broadcom-bgmac-b43.mk20
-rw-r--r--target/linux/brcm47xx/generic/profiles/221-Broadcom-bgmac-wl.mk20
-rw-r--r--target/linux/brcm47xx/generic/profiles/225-Broadcom-bgmac-none.mk18
-rw-r--r--target/linux/brcm47xx/generic/profiles/226-Broadcom-bgmac-brcsmac.mk20
-rw-r--r--target/linux/brcm47xx/generic/profiles/PS-1208MFG.mk18
-rw-r--r--target/linux/brcm47xx/generic/target.mk9
17 files changed, 0 insertions, 317 deletions
diff --git a/target/linux/brcm47xx/generic/profiles/100-Broadcom-b43.mk b/target/linux/brcm47xx/generic/profiles/100-Broadcom-b43.mk
deleted file mode 100644
index 4c420fb299..0000000000
--- a/target/linux/brcm47xx/generic/profiles/100-Broadcom-b43.mk
+++ /dev/null
@@ -1,20 +0,0 @@
-#
-# Copyright (C) 2007-2013 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-define Profile/Broadcom-b43
- NAME:=Broadcom SoC, all Ethernet, BCM43xx WiFi (b43, default)
- PACKAGES:=kmod-b44 kmod-tg3 kmod-bgmac kmod-b43 kmod-b43legacy
-endef
-
-define Profile/Broadcom-b43/Description
- Package set compatible with hardware any Broadcom BCM47xx or BCM535x
- SoC with Broadcom BCM43xx Wifi cards using the mac80211, b43 and
- b43legacy drivers and b44, tg3 or bgmac Ethernet driver.
-endef
-
-$(eval $(call Profile,Broadcom-b43))
-
diff --git a/target/linux/brcm47xx/generic/profiles/101-Broadcom-wl.mk b/target/linux/brcm47xx/generic/profiles/101-Broadcom-wl.mk
deleted file mode 100644
index c3e9d20c13..0000000000
--- a/target/linux/brcm47xx/generic/profiles/101-Broadcom-wl.mk
+++ /dev/null
@@ -1,20 +0,0 @@
-#
-# Copyright (C) 2010-2013 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-define Profile/Broadcom-wl
- NAME:=Broadcom SoC, all Ethernet, BCM43xx WiFi (wl, proprietary)
- PACKAGES:=-wpad-basic kmod-b44 kmod-tg3 kmod-bgmac kmod-brcm-wl wlc nas
-endef
-
-define Profile/Broadcom-wl/Description
- Package set compatible with hardware any Broadcom BCM47xx or BCM535x
- SoC with Broadcom BCM43xx Wifi cards using the proprietary Broadcom
- wireless "wl" driver and b44, tg3 or bgmac Ethernet driver.
-endef
-
-$(eval $(call Profile,Broadcom-wl))
-
diff --git a/target/linux/brcm47xx/generic/profiles/104-Broadcom-ath5k.mk b/target/linux/brcm47xx/generic/profiles/104-Broadcom-ath5k.mk
deleted file mode 100644
index ca5295f7e3..0000000000
--- a/target/linux/brcm47xx/generic/profiles/104-Broadcom-ath5k.mk
+++ /dev/null
@@ -1,19 +0,0 @@
-#
-# Copyright (C) 2006-2013 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-define Profile/Broadcom-ath5k
- NAME:=Broadcom SoC, all Ethernet, Atheros WiFi (ath5k)
- PACKAGES:=kmod-b44 kmod-tg3 kmod-bgmac kmod-ath5k
-endef
-
-define Profile/Broadcom-ath5k/Description
- Package set compatible with hardware any Broadcom BCM47xx or BCM535x
- SoC with Atheros Wifi cards using the mac80211 and ath5k drivers and
- b44, tg3 or bgmac Ethernet driver.
-endef
-$(eval $(call Profile,Broadcom-ath5k))
-
diff --git a/target/linux/brcm47xx/generic/profiles/105-Broadcom-none.mk b/target/linux/brcm47xx/generic/profiles/105-Broadcom-none.mk
deleted file mode 100644
index 4497124a2e..0000000000
--- a/target/linux/brcm47xx/generic/profiles/105-Broadcom-none.mk
+++ /dev/null
@@ -1,18 +0,0 @@
-#
-# Copyright (C) 2006-2013 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-define Profile/Broadcom-none
- NAME:=Broadcom SoC, all Ethernet, No WiFi
- PACKAGES:=-wpad-basic kmod-b44 kmod-tg3 kmod-bgmac
-endef
-
-define Profile/Broadcom-none/Description
- Package set compatible with hardware any Broadcom BCM47xx or BCM535x
- SoC without any Wifi cards and b44, tg3 or bgmac Ethernet driver.
-endef
-$(eval $(call Profile,Broadcom-none))
-
diff --git a/target/linux/brcm47xx/generic/profiles/200-Broadcom-b44-b43.mk b/target/linux/brcm47xx/generic/profiles/200-Broadcom-b44-b43.mk
deleted file mode 100644
index 662a7c8e94..0000000000
--- a/target/linux/brcm47xx/generic/profiles/200-Broadcom-b44-b43.mk
+++ /dev/null
@@ -1,20 +0,0 @@
-#
-# Copyright (C) 2007-2013 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-define Profile/Broadcom-b44-b43
- NAME:=Broadcom SoC, b44 Ethernet, BCM43xx WiFi (b43, default)
- PACKAGES:=kmod-b44 kmod-b43 kmod-b43legacy
-endef
-
-define Profile/Broadcom-b44-b43/Description
- Package set compatible with hardware older Broadcom BCM47xx or BCM535x
- SoC with Broadcom BCM43xx Wifi cards using the mac80211, b43 and
- b43legacy drivers and b44 Ethernet driver.
-endef
-
-$(eval $(call Profile,Broadcom-b44-b43))
-
diff --git a/target/linux/brcm47xx/generic/profiles/201-Broadcom-b44-wl.mk b/target/linux/brcm47xx/generic/profiles/201-Broadcom-b44-wl.mk
deleted file mode 100644
index 79b7c5c000..0000000000
--- a/target/linux/brcm47xx/generic/profiles/201-Broadcom-b44-wl.mk
+++ /dev/null
@@ -1,20 +0,0 @@
-#
-# Copyright (C) 2010-2013 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-define Profile/Broadcom-b44-wl
- NAME:=Broadcom SoC, b44 Ethernet, BCM43xx WiFi (wl, proprietary)
- PACKAGES:=-wpad-basic kmod-b44 kmod-brcm-wl wlc nas
-endef
-
-define Profile/Broadcom-b44-wl/Description
- Package set compatible with hardware older Broadcom BCM47xx or BCM535x
- SoC with Broadcom BCM43xx Wifi cards using the proprietary Broadcom
- wireless "wl" driver and b44 Ethernet driver.
-endef
-
-$(eval $(call Profile,Broadcom-b44-wl))
-
diff --git a/target/linux/brcm47xx/generic/profiles/204-Broadcom-b44-ath5k.mk b/target/linux/brcm47xx/generic/profiles/204-Broadcom-b44-ath5k.mk
deleted file mode 100644
index e9dda49d66..0000000000
--- a/target/linux/brcm47xx/generic/profiles/204-Broadcom-b44-ath5k.mk
+++ /dev/null
@@ -1,19 +0,0 @@
-#
-# Copyright (C) 2006-2013 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-define Profile/Broadcom-b44-ath5k
- NAME:=Broadcom SoC, b44 Ethernet, Atheros WiFi (ath5k)
- PACKAGES:=kmod-b44 kmod-ath5k
-endef
-
-define Profile/Broadcom-b44-ath5k/Description
- Package set compatible with hardware older Broadcom BCM47xx or BCM535x
- SoC with Atheros Wifi cards using the mac80211 and ath5k drivers and
- b44 Ethernet driver.
-endef
-$(eval $(call Profile,Broadcom-b44-ath5k))
-
diff --git a/target/linux/brcm47xx/generic/profiles/205-Broadcom-b44-none.mk b/target/linux/brcm47xx/generic/profiles/205-Broadcom-b44-none.mk
deleted file mode 100644
index 0854b5041e..0000000000
--- a/target/linux/brcm47xx/generic/profiles/205-Broadcom-b44-none.mk
+++ /dev/null
@@ -1,18 +0,0 @@
-#
-# Copyright (C) 2006-2013 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-define Profile/Broadcom-b44-none
- NAME:=Broadcom SoC, b44 Ethernet, No WiFi
- PACKAGES:=-wpad-basic kmod-b44
-endef
-
-define Profile/Broadcom-b44-none/Description
- Package set compatible with hardware older Broadcom BCM47xx or BCM535x
- SoC without any Wifi cards and b44 Ethernet driver.
-endef
-$(eval $(call Profile,Broadcom-b44-none))
-
diff --git a/target/linux/brcm47xx/generic/profiles/210-Broadcom-tg3-b43.mk b/target/linux/brcm47xx/generic/profiles/210-Broadcom-tg3-b43.mk
deleted file mode 100644
index a0bece914d..0000000000
--- a/target/linux/brcm47xx/generic/profiles/210-Broadcom-tg3-b43.mk
+++ /dev/null
@@ -1,20 +0,0 @@
-#
-# Copyright (C) 2007-2013 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-define Profile/Broadcom-tg3-b43
- NAME:=Broadcom SoC, tg3 Ethernet, BCM43xx WiFi (b43)
- PACKAGES:=kmod-b43 kmod-tg3
-endef
-
-define Profile/Broadcom-tg3-b43/Description
- Package set compatible with hardware Broadcom BCM4705/BCM4785
- SoCs with Broadcom BCM43xx Wifi cards using the mac80211 and b43
- driver and tg3 Ethernet driver.
-endef
-
-$(eval $(call Profile,Broadcom-tg3-b43))
-
diff --git a/target/linux/brcm47xx/generic/profiles/211-Broadcom-tg3-wl.mk b/target/linux/brcm47xx/generic/profiles/211-Broadcom-tg3-wl.mk
deleted file mode 100644
index 6946668c91..0000000000
--- a/target/linux/brcm47xx/generic/profiles/211-Broadcom-tg3-wl.mk
+++ /dev/null
@@ -1,20 +0,0 @@
-#
-# Copyright (C) 2010-2013 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-define Profile/Broadcom-tg3-wl
- NAME:=Broadcom SoC, tg3 Ethernet, BCM43xx WiFi (wl, proprietary)
- PACKAGES:=-wpad-basic kmod-brcm-wl wlc nas kmod-tg3
-endef
-
-define Profile/Broadcom-tg3-wl/Description
- Package set compatible with hardware Broadcom BCM4705/BCM4785
- SoC with Broadcom BCM43xx Wifi cards using the proprietary Broadcom
- wireless "wl" driver and tg3 Ethernet driver.
-endef
-
-$(eval $(call Profile,Broadcom-tg3-wl))
-
diff --git a/target/linux/brcm47xx/generic/profiles/215-Broadcom-tg3-none.mk b/target/linux/brcm47xx/generic/profiles/215-Broadcom-tg3-none.mk
deleted file mode 100644
index a5a3b4a010..0000000000
--- a/target/linux/brcm47xx/generic/profiles/215-Broadcom-tg3-none.mk
+++ /dev/null
@@ -1,18 +0,0 @@
-#
-# Copyright (C) 2006-2013 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-define Profile/Broadcom-tg3-none
- NAME:=Broadcom SoC, tg3 Ethernet, no WiFi
- PACKAGES:=-wpad-basic kmod-tg3
-endef
-
-define Profile/Broadcom-tg3-none/Description
- Package set compatible with hardware Broadcom BCM4705/BCM4785
- SoC without any Wifi cards and tg3 Ethernet driver.
-endef
-$(eval $(call Profile,Broadcom-tg3-none))
-
diff --git a/target/linux/brcm47xx/generic/profiles/220-Broadcom-bgmac-b43.mk b/target/linux/brcm47xx/generic/profiles/220-Broadcom-bgmac-b43.mk
deleted file mode 100644
index 6ef0691a4c..0000000000
--- a/target/linux/brcm47xx/generic/profiles/220-Broadcom-bgmac-b43.mk
+++ /dev/null
@@ -1,20 +0,0 @@
-#
-# Copyright (C) 2007-2013 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-define Profile/Broadcom-bgmac-b43
- NAME:=Broadcom SoC, bgmac Ethernet, BCM43xx WiFi (b43)
- PACKAGES:=kmod-bgmac kmod-b43
-endef
-
-define Profile/Broadcom-bgmac-b43/Description
- Package set compatible with hardware newer Broadcom BCM47xx or BCM535x
- SoC with Broadcom BCM43xx Wifi cards using the mac80211 and b43
- drivers and bgmac Ethernet driver.
-endef
-
-$(eval $(call Profile,Broadcom-bgmac-b43))
-
diff --git a/target/linux/brcm47xx/generic/profiles/221-Broadcom-bgmac-wl.mk b/target/linux/brcm47xx/generic/profiles/221-Broadcom-bgmac-wl.mk
deleted file mode 100644
index acdc20fb70..0000000000
--- a/target/linux/brcm47xx/generic/profiles/221-Broadcom-bgmac-wl.mk
+++ /dev/null
@@ -1,20 +0,0 @@
-#
-# Copyright (C) 2010-2013 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-define Profile/Broadcom-bgmac-wl
- NAME:=Broadcom SoC, bgmac Ethernet, BCM43xx WiFi (wl, proprietary)
- PACKAGES:=-wpad-basic kmod-bgmac kmod-brcm-wl wlc nas
-endef
-
-define Profile/Broadcom-bgmac-wl/Description
- Package set compatible with hardware newer Broadcom BCM47xx or BCM535x
- SoC with Broadcom BCM43xx Wifi cards using the proprietary Broadcom
- wireless "wl" driver and bgmac Ethernet driver.
-endef
-
-$(eval $(call Profile,Broadcom-bgmac-wl))
-
diff --git a/target/linux/brcm47xx/generic/profiles/225-Broadcom-bgmac-none.mk b/target/linux/brcm47xx/generic/profiles/225-Broadcom-bgmac-none.mk
deleted file mode 100644
index db2d1a264c..0000000000
--- a/target/linux/brcm47xx/generic/profiles/225-Broadcom-bgmac-none.mk
+++ /dev/null
@@ -1,18 +0,0 @@
-#
-# Copyright (C) 2006-2013 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-define Profile/Broadcom-bgmac-none
- NAME:=Broadcom SoC, bgmac Ethernet, No WiFi
- PACKAGES:=-wpad-basic kmod-bgmac
-endef
-
-define Profile/Broadcom-bgmac-none/Description
- Package set compatible with hardware newer Broadcom BCM47xx or BCM535x
- SoC without any Wifi cards and bgmac Ethernet driver.
-endef
-$(eval $(call Profile,Broadcom-bgmac-none))
-
diff --git a/target/linux/brcm47xx/generic/profiles/226-Broadcom-bgmac-brcsmac.mk b/target/linux/brcm47xx/generic/profiles/226-Broadcom-bgmac-brcsmac.mk
deleted file mode 100644
index d9dc9e7a4a..0000000000
--- a/target/linux/brcm47xx/generic/profiles/226-Broadcom-bgmac-brcsmac.mk
+++ /dev/null
@@ -1,20 +0,0 @@
-#
-# Copyright (C) 2007-2013 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-define Profile/Broadcom-bgmac-brcmsmac
- NAME:=Broadcom SoC, bgmac Ethernet, BCM43xx WiFi (brcmsmac)
- PACKAGES:=kmod-bgmac kmod-brcmsmac
-endef
-
-define Profile/Broadcom-bgmac-brcmsmac/Description
- Package set compatable with newer gigabit + N based bcm47xx SoCs with
- Broadcom BCM43xx Wifi cards using the mac80211 brcmsmac driver and
- bgmac Ethernet driver.
-endef
-
-$(eval $(call Profile,Broadcom-bgmac-brcmsmac))
-
diff --git a/target/linux/brcm47xx/generic/profiles/PS-1208MFG.mk b/target/linux/brcm47xx/generic/profiles/PS-1208MFG.mk
deleted file mode 100644
index 14ee46f200..0000000000
--- a/target/linux/brcm47xx/generic/profiles/PS-1208MFG.mk
+++ /dev/null
@@ -1,18 +0,0 @@
-#
-# Copyright (C) 2007-2010 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-define Profile/Ps1208mfg
- NAME:=Edimax PS-1208MFG
- PACKAGES:=-firewall -dropbear -dnsmasq -mtd -ppp -wpad-basic kmod-b44 block-mount kmod-usb-storage kmod-usb2 kmod-usb-ohci -iptables -swconfig kmod-fs-ext4
-endef
-
-define Profile/Ps1208mfg/Description
- Package set optimize for edimax PS-1208MFG printserver
-endef
-
-$(eval $(call Profile,Ps1208mfg))
-
diff --git a/target/linux/brcm47xx/generic/target.mk b/target/linux/brcm47xx/generic/target.mk
deleted file mode 100644
index 2f93778b09..0000000000
--- a/target/linux/brcm47xx/generic/target.mk
+++ /dev/null
@@ -1,9 +0,0 @@
-BOARDNAME:=Generic
-FEATURES+=pcmcia
-
-DEFAULT_PACKAGES += wpad-basic
-
-define Target/Description
- Build generic firmware for all Broadcom BCM47xx and BCM53xx MIPS
- devices. It runs on both architectures BMIPS3300 and MIPS 74K.
-endef