aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/brcm47xx-2.6/files/drivers/ssb/Makefile
diff options
context:
space:
mode:
authorPeter Denison <openwrt@marshadder.org>2007-06-21 20:10:50 +0000
committerPeter Denison <openwrt@marshadder.org>2007-06-21 20:10:50 +0000
commit0f3100df555289b57b816f1fb767a9908bf862cd (patch)
tree3484c631f3eaea7fccab2fa15ffab748837f1709 /target/linux/brcm47xx-2.6/files/drivers/ssb/Makefile
parentb94b11e11eee8b43ec951f46afc446bfaaebb87c (diff)
downloadupstream-0f3100df555289b57b816f1fb767a9908bf862cd.tar.gz
upstream-0f3100df555289b57b816f1fb767a9908bf862cd.tar.bz2
upstream-0f3100df555289b57b816f1fb767a9908bf862cd.zip
brcm43xx: update SSB driver * files/ now contains the wireless-dev tree version * patches/210-ssb_merge is nbd's subsequent changes
SVN-Revision: 7691
Diffstat (limited to 'target/linux/brcm47xx-2.6/files/drivers/ssb/Makefile')
-rw-r--r--target/linux/brcm47xx-2.6/files/drivers/ssb/Makefile17
1 files changed, 7 insertions, 10 deletions
diff --git a/target/linux/brcm47xx-2.6/files/drivers/ssb/Makefile b/target/linux/brcm47xx-2.6/files/drivers/ssb/Makefile
index 9f85d225dd..9a2b379fbf 100644
--- a/target/linux/brcm47xx-2.6/files/drivers/ssb/Makefile
+++ b/target/linux/brcm47xx-2.6/files/drivers/ssb/Makefile
@@ -1,14 +1,11 @@
-ssb-driver-chipcommon-y := driver_chipcommon/chipcommon.o
-ssb-driver-mips-$(CONFIG_BCM947XX) := driver_mips/mips.o
-ssb-driver-pci-$(CONFIG_SSB_DRIVER_PCICORE) := driver_pci/pcicore.o
+ssb-builtin-drivers-y += driver_chipcommon.o
+ssb-builtin-drivers-$(CONFIG_SSB_DRIVER_MIPS) += driver_mipscore.o
+ssb-builtin-drivers-$(CONFIG_SSB_DRIVER_PCICORE) += driver_pcicore.o
-ssb-$(CONFIG_SSB_PCIHOST) += pci.o
-ssb-$(CONFIG_SSB_PCMCIAHOST) += pcmcia.o
+ssb-hostsupport-$(CONFIG_SSB_PCIHOST) += pci.o pcihost_wrapper.o
+ssb-hostsupport-$(CONFIG_SSB_PCMCIAHOST) += pcmcia.o
obj-$(CONFIG_SSB) += ssb.o
-ssb-objs := core.o scan.o \
- $(ssb-y) $(ssb-m) \
- $(ssb-driver-chipcommon-y) \
- $(ssb-driver-mips-y) \
- $(ssb-driver-pci-y)
+ssb-objs := main.o scan.o \
+ $(ssb-hostsupport-y) $(ssb-builtin-drivers-y)